Bug 58469 - ONBOOT=no does not work for wireless interface
Summary: ONBOOT=no does not work for wireless interface
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wireless-tools   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-17 16:06 UTC by Bill Moss
Modified: 2014-03-17 02:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 21:18:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Moss 2002-01-17 16:06:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Using the network configuration tool to set the wireless interface to NOT START 
at boot (ONBOOT=no in /etc/sysconfig/network-scripts/ifcfg-eht1) does not work. 
Also, the wireless card parameters are stored in ifcfg-eth1 and are read from 
the file at boot, not from the /etc/pcmcia wireless.opts file. cardctl eject 2 
followed by cardctl insert 2 causes the wireless card to be stopped and then 
reconfigured using wireless.opts. RH is no longer using network.opts and the 
network starup up scripts is infact by-passing the OPTS files at boot. Not 
being able to boot and have the wireless interface not come up is a pain in 
certain situations where you have a choice of wired and wireless interfaces. It 
would also be nice if the drivers (here orinoco_cs) implemented the TXPOWER 
parameter so that using iwconfig eth1 TXPOWER off, you could turn off the 
wireless radio like you can do under Windows 2000.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. configure wireless interface not to start at boot
2. reboot
3. ifconfig show that the wireless interface did start at boot
	

Additional info:

Comment 1 Bill Nottingham 2005-01-17 21:18:31 UTC
This is because it's brought up from hotplug; you can set ONHOTPLUG=no.


Note You need to log in before you can comment on or make changes to this bug.