Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 584710 - SELinux is preventing /usr/bin/pulseaudio "setattr" access on /var/lib/mpd/.pulse.
SELinux is preventing /usr/bin/pulseaudio "setattr" access on /var/lib/m...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:27f341e7cb6...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 05:02 EDT by Robert Townley
Modified: 2010-06-04 14:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.6.32-116.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 14:57:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Townley 2010-04-22 05:02:02 EDT
Summary:

SELinux is preventing /usr/bin/pulseaudio "setattr" access on
/var/lib/mpd/.pulse.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by pulseaudio. It is not expected that this
access is required by pulseaudio and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:pulseaudio_t:s0
Target Context                unconfined_u:object_r:var_lib_t:s0
Target Objects                /var/lib/mpd/.pulse [ dir ]
Source                        pulseaudio
Source Path                   /usr/bin/pulseaudio
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           pulseaudio-0.9.21-5.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-110.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.i686.PAE #1
                              SMP Mon Apr 5 16:15:03 EDT 2010 i686 i686
Alert Count                   5
First Seen                    Thu 22 Apr 2010 02:07:12 AM CDT
Last Seen                     Thu 22 Apr 2010 04:00:54 AM CDT
Local ID                      0f7b51f8-2fef-44d9-9993-3b65b32c7bfe
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1271926854.758:29787): avc:  denied  { setattr } for  pid=10651 comm="pulseaudio" name=".pulse" dev=dm-0 ino=172094 scontext=unconfined_u:system_r:pulseaudio_t:s0 tcontext=unconfined_u:object_r:var_lib_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1271926854.758:29787): arch=40000003 syscall=212 success=yes exit=0 a0=b6a00520 a1=1ee a2=1db a3=b6a00520 items=0 ppid=10641 pid=10651 auid=500 uid=494 gid=475 euid=494 suid=494 fsuid=494 egid=475 sgid=475 fsgid=475 tty=(none) ses=4 comm="pulseaudio" exe="/usr/bin/pulseaudio" subj=unconfined_u:system_r:pulseaudio_t:s0 key=(null)



Hash String generated from  catchall,pulseaudio,pulseaudio_t,var_lib_t,dir,setattr
audit2allow suggests:

#============= pulseaudio_t ==============
allow pulseaudio_t var_lib_t:dir setattr;
Comment 1 Daniel Walsh 2010-04-22 07:43:16 EDT
Was /var/lib/mpd a local customization?

# semange fcontext -a -t pulseaudio_var_lib_t '/var/lib/mpd(/.*)?'
# restorecon -R -v /var/lib/mpd

Should fix.
Comment 2 Miroslav Grepl 2010-04-29 04:48:27 EDT
I am closing it as CANTFIX. That's relating to Music Player Daemon.
Comment 3 Robert Townley 2010-05-01 14:48:46 EDT
i thank you for spending time on a daemon that is not in the Fedora repos.  Is it a CANTFIX simply because it is not in the official Fedora repos or does the mpd use pulseaudio in a way that would never be compatible with selinux.
Comment 4 Daniel Walsh 2010-05-03 14:09:16 EDT
Does the lines above fix the problem?
Comment 5 Robert Townley 2010-05-05 04:59:02 EDT
After doing the following again, that selinux issue no longer appears.  

# semanage fcontext -a -t pulseaudio_var_lib_t '/var/lib/mpd(/.*)?'
# restorecon -R -v /var/lib/mpd
Comment 6 Daniel Walsh 2010-05-05 10:52:33 EDT
That is what the current policy has for labeling.  If you can get mpd into fedora, we will write policy for it.

Miroslav can you add this labeling to F12.  It is in F13.
Comment 7 Miroslav Grepl 2010-05-11 09:16:44 EDT
Fixed in selinux-policy-3.6.32-115.fc12
Comment 8 Fedora Update System 2010-05-21 09:52:11 EDT
selinux-policy-3.6.32-116.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-116.fc12
Comment 9 Fedora Update System 2010-05-24 15:34:13 EDT
selinux-policy-3.6.32-116.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-116.fc12
Comment 10 Fedora Update System 2010-06-04 14:57:01 EDT
selinux-policy-3.6.32-116.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.