Bug 584760 - [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox wa...
Status: CLOSED DUPLICATE of bug 583959
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: 12
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:421c704be65fa34c2c8f9b1f945...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-22 10:57 UTC by William Henry
Modified: 2010-05-08 13:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-08 13:53:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (72.62 KB, text/plain)
2010-04-22 10:58 UTC, William Henry
no flags Details

Description William Henry 2010-04-22 10:57:59 UTC
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.5/firefox
comment: read the above
component: firefox
executable: /usr/lib/firefox-3.5/firefox
kernel: 2.6.32.11-99.fc12.i686
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.did google search for google earth for linux 
2.Clicked on a one of the displayed results
3.As page was begining to change I saw and clicked on another result. Then crash

Comment 1 William Henry 2010-04-22 10:58:06 UTC
Created attachment 408288 [details]
File: backtrace

Comment 2 Chris Campbell 2010-05-08 13:50:58 UTC
#3  <signal handler called>
No symbol table info available.
#4  JS_ClearScope (cx=0xa8b0ac00, obj=0x0) at jsapi.cpp:3946
No locals.
#5  0x0118ca23 in ClearNativeWrapperScope (table=0xb7179580, hdr=0x9d146000, 
    number=358, arg=0xbfdfea88) at XPCNativeWrapper.cpp:1325
        d = 0xbfdfea88
#6  0x0075fe3f in JS_DHashTableEnumerate (table=0xb7179580, etor=
    0x118c9f2 <ClearNativeWrapperScope(JSDHashTable*, JSDHashEntryHdr*, uint32, void*)>, arg=0xbfdfea88) at jsdhash.cpp:724
        entryAddr = 0x9d146000 ""
        i = 359
        capacity = <value optimized out>
        entrySize = 8
        didRemove = 0
        entryLimit = 0x9d149000 ""
        entry = 0x9d146000
#7  0x0118ca9a in Enumerate (cx=0xa8b0ac00, wrapper=0x9e842e20)
    at xpcmaps.h:630
No locals.
#8  XPCNativeWrapper::ClearWrappedNativeScopes (cx=0xa8b0ac00, wrapper=
    0x9e842e20) at XPCNativeWrapper.cpp:1349
        nativeWrapper = <value optimized out>
        d = {wrapper = 0x9e842e20, cx = 0xa8b0ac00}
#9  0x0118a536 in XPC_WN_JSOp_Clear (cx=0xa8b0ac00, obj=0xae2c5860)
    at xpcwrappednativejsops.cpp:1273
        xpc = <value optimized out>
        wrapper = 0x9e842e20
#10 0x0074bff8 in JS_ClearScope (cx=0xa8b0ac00, obj=0xae2c5860)
    at jsapi.cpp:3947
No locals.
#11 0x01598df5 in nsJSContext::ClearScope (this=0x9d8483c0, aGlobalObj=
    0xae2c5860, aClearFromProtoChain=0) at nsJSEnvironment.cpp:3350
        obj = 0xae2c5860
        ar = {mContext = 0xa8b0ac00, mSaveDepth = 0}
        stack = {<nsCOMPtr_base> = {mRawPtr = 0xb71644fc}, <No data fi



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Chris Campbell 2010-05-08 13:53:08 UTC
Thank you for taking the time to submit this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 583959 ***


Note You need to log in before you can comment on or make changes to this bug.