Bug 58481 - RFE: Ability to pull driver disk from cd-rom or network
Summary: RFE: Ability to pull driver disk from cd-rom or network
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 81679
TreeView+ depends on / blocked
 
Reported: 2002-01-17 20:55 UTC by Antoine Adams
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-25 16:14:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Antoine Adams 2002-01-17 20:55:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
It is not possible to add drivers from a cd-rom or network connection. This is 
a big problem especially installing colo placed servers which in 99% nowadays 
don't have a floppy disk. Also remote installs AMS->Nigeria (shell) makes it 
very hard. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Buy servelinux 1U mini
2. try installing it. (bus sees disks as ide i.s.o. scsi with ft driver
3.
	

Actual Results:  After install, Device errors in the log

Expected Results:  harddrive should have been seen as sda1

Additional info:

Call for more info on this topic:

+31 70 404 4444
or
mail: antoine.a.adams@is.shell.com / antoine@nebula.nl

Comment 1 Erik Troan 2002-02-15 16:14:32 UTC
Are you asking for a feature similiary to the current driver disk option thta
loads from different media, or something else?

Comment 2 Antoine Adams 2002-02-15 18:23:55 UTC
It's accually 2 things in one. 1 the fasttrack driver isn't working but alan is
busy with that so that goes away. 
Then is exactly as the driver disk but then be able to choose the media type,

/dev/cdrom
/dev/fd0
via httpd, ftp or nfs (this one prob is difficult) bui the first two would save
a lot. Because you can make a driver CD by yourselve

Comment 3 Jeremy Katz 2002-04-09 00:44:00 UTC
Deferring to a future release

Comment 4 Jeremy Katz 2003-01-15 00:41:01 UTC
Pulling drivers from a CD-ROM drive is now supported.  Network driver disks
aren't going to be supported in interactive installs at the current time.

Comment 5 Mike McLean 2003-01-21 20:18:35 UTC
I am unable to pull a driver disk from cdrom.  I'm getting "Failed to mount
driver disk".  This is an ide DVD/CD-RW in a Thinkpad A31.

Comment 6 Mike McLean 2003-01-21 20:19:18 UTC
That was with Phoebe public beta 2

Comment 7 Jeremy Katz 2003-02-07 20:38:13 UTC
Added mounting iso9660 fs's

Comment 8 Mike McLean 2003-06-25 16:14:03 UTC
closing.  loading drivers via cdrom is possible with Red Hat Linux 9.  


Note You need to log in before you can comment on or make changes to this bug.