Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 584815 - SELinux is preventing /sbin/setfiles access to a leaked /ffc.log file descriptor.
SELinux is preventing /sbin/setfiles access to a leaked /ffc.log file descrip...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:5db397ea4dd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 09:44 EDT by Jay Greguske
Modified: 2010-07-29 12:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 12:50:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Greguske 2010-04-22 09:44:17 EDT
Summary:

SELinux is preventing /sbin/setfiles access to a leaked /ffc.log file
descriptor.

Detailed Description:

[setfiles has a permissive type (setfiles_t). This access was not denied.]

SELinux denied access requested by the setfiles command. It looks like this is
either a leaked descriptor or setfiles output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the /ffc.log. You should generate a bugzilla on selinux-policy, and it will get
routed to the appropriate package. You can safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:object_r:etc_runtime_t:s0
Target Objects                /ffc.log [ file ]
Source                        setfiles
Source Path                   /sbin/setfiles
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           policycoreutils-2.0.81-3.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.15-4.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux localhost.localdomain
                              2.6.33.1-24.fc13.x86_64 #1 SMP Tue Mar 30 18:21:22
                              UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Thu 22 Apr 2010 01:30:17 PM EDT
Last Seen                     Thu 22 Apr 2010 01:30:17 PM EDT
Local ID                      4b166a4b-b0f1-41a4-9b68-0c0b5db342be
Line Numbers                  

Raw Audit Messages            

node=localhost.localdomain type=AVC msg=audit(1271957417.109:21183): avc:  denied  { append } for  pid=1964 comm="setfiles" path="/ffc.log" dev=dm-0 ino=80384 scontext=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:etc_runtime_t:s0 tclass=file

node=localhost.localdomain type=SYSCALL msg=audit(1271957417.109:21183): arch=c000003e syscall=59 success=yes exit=0 a0=17989f0 a1=1787010 a2=17832c0 a3=7fffa4461a70 items=0 ppid=1943 pid=1964 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=1 comm="setfiles" exe="/sbin/setfiles" subj=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  leaks,setfiles,setfiles_t,etc_runtime_t,file,append
audit2allow suggests:

#============= setfiles_t ==============
allow setfiles_t etc_runtime_t:file append;

Note You need to log in before you can comment on or make changes to this bug.