Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 584817 - DeviceError: ('cannot replace active format', 'sda1')
DeviceError: ('cannot replace active format', 'sda1')
Status: CLOSED DUPLICATE of bug 563526
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 09:50 EDT by Brian Wheeler
Modified: 2010-04-22 13:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-22 13:05:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Wheeler 2010-04-22 09:50:42 EDT
The following was filed automatically by anaconda:
anaconda 13.21.20.5 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 697, in _setFormat
    raise DeviceError("cannot replace active format", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 1171, in _setFormat
    StorageDevice._setFormat(self, format)
  File "/usr/lib/anaconda/storage/devices.py", line 705, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/anaconda/storage/deviceaction.py", line 307, in __init__
    self.device.format = None
  File "/usr/lib/anaconda/storage/__init__.py", line 782, in destroyDevice
    self.devicetree.registerAction(ActionDestroyFormat(device))
  File "/usr/lib/anaconda/storage/partitioning.py", line 370, in clearPartitions
    storage.destroyDevice(part)
  File "/usr/lib/anaconda/storage/partitioning.py", line 184, in doAutoPartition
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1396, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1309, in nextClicked
    self.setScreen ()
DeviceError: ('cannot replace active format', 'sda1')
Comment 1 Brian Wheeler 2010-04-22 10:25:38 EDT
I get this failure with I choose "use all, review+modify" or if I choose "custom layout, and try to delete /dev/sda1".  In the latter case, the partition was a bog-standard 200M type 83 active partition.  I was able to use fdisk and remove the partition without incident and restarting the install worked as expected.
Comment 3 RHEL Product and Program Management 2010-04-22 12:16:35 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Chris Lumens 2010-04-22 13:05:18 EDT

*** This bug has been marked as a duplicate of bug 563526 ***

Note You need to log in before you can comment on or make changes to this bug.