Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 584819 - qmf-generated code fails to build using qpid_win_sdk.zip
Summary: qmf-generated code fails to build using qpid_win_sdk.zip
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: Development
Hardware: All
OS: Windows
high
high
Target Milestone: 1.3
: ---
Assignee: Andrew Stitcher
QA Contact: Frantisek Reznicek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-22 14:00 UTC by Timothy St. Clair
Modified: 2015-11-16 01:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-20 11:30:24 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Timothy St. Clair 2010-04-22 14:00:37 UTC
Description of problem:
qmf generated code includes files which are not in the distribution on windows. 

.\mrg\grid\Master.cpp(27) : fatal error C1083: Cannot open include file: 'qpid/amqp_0_10/Codecs.h': No such file or directory

Version-Release number of selected component (if applicable):
qpid-cpp-0.7.935473-1.zip

How reproducible:
100%

Steps to Reproduce:
1. Build grid package on windows.

Comment 1 Andrew Stitcher 2010-04-22 14:52:04 UTC
Looks like a simple omission from the includes shipped in the sdk - now testing a version with qpid/amqp_0_10/Codec.h included.

Comment 2 Andrew Stitcher 2010-04-22 20:47:23 UTC
Upstream version 936960 should have a fix for this

Comment 3 Frantisek Reznicek 2010-06-09 08:09:16 UTC
The issue has been fixed.
qpid-cpp-0.7.946106-x.zip package contains the Codecs.h header and MRG/G build succeeded (for instance build #59).

-> VERIFIED


Note You need to log in before you can comment on or make changes to this bug.