Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 584825 - Remove not necessary linking to libpcre
Remove not necessary linking to libpcre
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
1.0
All Linux
low Severity medium
: 2.0
: ---
Assigned To: Matthew Farrellee
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 10:16 EDT by Luigi Toscano
Modified: 2011-02-03 12:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-03 12:12:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luigi Toscano 2010-04-22 10:16:19 EDT
Description of problem:
This a followup of bz471054: many executables in the condor package links to libpcre.

/usr/bin/condor
/usr/bin/condor_check_userlogs
/usr/bin/condor_cod
/usr/bin/condor_config_val
/usr/bin/condor_dagman
/usr/bin/condor_findhost
/usr/bin/condor_history
/usr/bin/condor_hold
/usr/bin/condor_prio
/usr/bin/condor_q
/usr/bin/condor_qedit
/usr/bin/condor_release
/usr/bin/condor_reschedule
/usr/bin/condor_rm
/usr/bin/condor_ssh_to_job
/usr/bin/condor_stats
/usr/bin/condor_status
/usr/bin/condor_submit
/usr/bin/condor_submit_dag
/usr/bin/condor_transfer_data
/usr/bin/condor_userlog
/usr/bin/condor_userlog_job_counter
/usr/bin/condor_userprio
/usr/bin/condor_vacate
/usr/bin/condor_vacate_job
/usr/bin/condor_version
/usr/bin/condor_wait
/usr/sbin/condor_advertise
/usr/sbin/condor_c-gahp
/usr/sbin/condor_c-gahp_worker_thread
/usr/sbin/condor_collector
/usr/sbin/condor_fetchlog
/usr/sbin/condor_gridmanager
/usr/sbin/condor_had
/usr/sbin/condor_master
/usr/sbin/condor_negotiator
/usr/sbin/condor_off
/usr/sbin/condor_on
/usr/sbin/condor_preen
/usr/sbin/condor_reconfig
/usr/sbin/condor_replication
/usr/sbin/condor_restart
/usr/sbin/condor_schedd
/usr/sbin/condor_shadow
/usr/sbin/condor_startd
/usr/sbin/condor_starter
/usr/sbin/condor_store_cred
/usr/sbin/condor_transferd
/usr/sbin/condor_transferer

Is it the intended behaviour, or can this list be reduced a bit?

Version-Release number of selected component (if applicable):
condor-7.4.3-0.11 (RHEL5.5/4.8, i386/x86_64).
Comment 1 Matthew Farrellee 2011-02-03 12:12:35 EST
The set cannot be easily reduced. Anything that links with classads (which is most everything) also must link with pcre.

The most unfortunate case is of course the condor_shadow, were it is desirable to have a memory footprint that is as small as possible.

Note You need to log in before you can comment on or make changes to this bug.