Bug 584832 - xorg-x11-server-1.8.0-7.fc13 hangs when compiz starts
Summary: xorg-x11-server-1.8.0-7.fc13 hangs when compiz starts
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: card_IGP600/MiI
Keywords:
: 597063 (view as bug list)
Depends On:
Blocks: F13Blocker, F13FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2010-04-22 14:33 UTC by Michal Schmidt
Modified: 2010-06-04 05:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 21:04:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (52.90 KB, text/plain)
2010-04-22 14:34 UTC, Michal Schmidt
no flags Details
Xorg.0.log (82.57 KB, text/plain)
2010-04-22 14:35 UTC, Michal Schmidt
no flags Details

Description Michal Schmidt 2010-04-22 14:33:03 UTC
Description of problem:
This is a fresh regression.
I updated from xorg-x11-server-1.8.0-6.fc13 to xorg-x11-server-1.8.0-7.fc13 (currently in updates-testing). Xorg hangs after I login to a Gnome session with compiz enabled. Other processes continue to run and I can ssh into the machine. Xorg stays in D state. Its kernel stack trace is:

[<ffffffffa00ac3ef>] radeon_cs_ioctl+0x37/0x1a0 [radeon] 
[<ffffffffa0019418>] drm_ioctl+0x28f/0x373 [drm] 
[<ffffffff8112d108>] vfs_ioctl+0x32/0xa6 
[<ffffffff8112d688>] do_vfs_ioctl+0x490/0x4d6 
[<ffffffff8112d724>] sys_ioctl+0x56/0x79 
[<ffffffff81009c72>] system_call_fastpath+0x16/0x1b 
[<ffffffffffffffff>] 0xffffffffffffffff

It works fine when metacity is used instead of compiz and then it even runs glxgears without trouble. Downgrading to xorg-x11-server-1.8.0-6.fc13 also fixes it.

Version-Release number of selected component (if applicable):
kernel-2.6.33.2-57.fc13.x86_64
xorg-x11-drv-ati-6.13.0-1.fc13.x86_64
xorg-x11-server-Xorg-1.8.0-7.fc13.x86_64

How reproducible:
100% reproducible.

Steps to Reproduce:
1. start compiz
  
Actual results:
Xorg hangs

Expected results:
no hang

Comment 1 Michal Schmidt 2010-04-22 14:34:51 UTC
Created attachment 408342 [details]
dmesg

This dmesg was taken when Xorg was already stuck.

Comment 2 Michal Schmidt 2010-04-22 14:35:50 UTC
Created attachment 408343 [details]
Xorg.0.log

Xorg.0.log taken at the same time

Comment 3 Michal Schmidt 2010-04-22 14:39:09 UTC
Assigning to Ajax because he made the change that broke it:
* Tue Apr 20 2010 Adam Jackson <ajax@...> 1.8.0-7
- xserver-1.8.0-glxdri2-resource-conversion.patch: Fix crash on exit from
  GLX apps with DRI2 drivers. (#579756)

Comment 4 Adam Williamson 2010-04-23 20:28:28 UTC
can you please test if -8 changes anything? It's not specifically to fix this bug, but it does fix something introduced in the -7 change, so it may affect you.

Discussed at the blocker review meeting today, agreed to add this as a blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Michal Schmidt 2010-04-23 21:04:49 UTC
I installed -7 again to make sure the bug was still reproducible. It was.
Then I updated to xorg-x11-server-1.8.0-8.fc13 and now X with compiz works
fine! The bug seems fixed.

Closing this bug as WORKSFORME (I never remember what is the proper resolution
for a bug which was only present in a build from updates-testing and was never
pushed to stable.)

Comment 6 Ville-Pekka Vainio 2010-04-23 21:09:00 UTC
I had this bug too and xorg-x11-server-1.8.0-8.fc13 works. Thanks.

Comment 7 Adam Williamson 2010-04-24 01:18:43 UTC
michal: we don't have an 'official' resolution for that case. I'd probably use ERRATA, but don't sweat too much about resolutions, we only occasionally actually use them for anything :)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 8 Matthias Runge 2010-04-24 19:18:46 UTC
Versions I have:
xorg-x11-server-Xorg-1.8.0-7.fc13.i686

Crash occurs, when enabling compiz.

Comment 9 Bill Newton 2010-06-04 05:15:57 UTC
*** Bug 597063 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.