Bug 584839 - DeviceError: ('cannot replace active format', 'sda5')
DeviceError: ('cannot replace active format', 'sda5')
Status: CLOSED DUPLICATE of bug 563526
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
Depends On:
  Show dependency treegraph
Reported: 2010-04-22 10:41 EDT by Alan Ernhart
Modified: 2010-05-15 00:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-04-22 13:06:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Attached traceback automatically from anaconda. (159.00 KB, text/plain)
2010-04-22 10:41 EDT, Alan Ernhart
no flags Details
Attached traceback automatically from anaconda. (186.09 KB, text/plain)
2010-05-15 00:07 EDT, Vinny
no flags Details

  None (edit)
Description Alan Ernhart 2010-04-22 10:41:20 EDT
The following was filed automatically by anaconda:
anaconda exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 697, in _setFormat
    raise DeviceError("cannot replace active format", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 1171, in _setFormat
    StorageDevice._setFormat(self, format)
  File "/usr/lib/anaconda/storage/devices.py", line 705, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/anaconda/storage/deviceaction.py", line 259, in __init__
    self.device.format = format
  File "/usr/lib/anaconda/iw/partition_dialog_gui.py", line 285, in run
    actions.append(ActionCreateFormat(usedev, format))
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1676, in editPartition
    actions = parteditor.run()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1640, in editCB
DeviceError: ('cannot replace active format', 'sda5')
Comment 1 Alan Ernhart 2010-04-22 10:41:31 EDT
Created attachment 408344 [details]
Attached traceback automatically from anaconda.
Comment 2 Alan Ernhart 2010-04-22 11:25:59 EDT
I've burned RHEL6.0-20100414.0-AP-i386-DVD1.iso onto DVD and am installing from it onto an IBM model 8187T9U desktop system. This has two physical drives, one of which is only data.

The other drive is partitioned for multi-boot, already having 4 flavors of Linux, each rooted on one partition.

Anaconda is failing when selecting one of these to format as ext4 and mount on /. This partition currently has RHEL4 on it, formatted in ext3. The partition is Number 5 on hda below:

# parted --list

Model: Maxtor 6Y120L0 (ide)
Disk /dev/hda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      32.3kB  419MB   419MB   primary   ext3         boot
 2      419MB   120GB   120GB   extended
 5      420MB   42.4GB  41.9GB  logical   ext3
 6      42.4GB  84.3GB  41.9GB  logical   ext3
 7      84.3GB  88.5GB  4195MB  logical   linux-swap
 8      88.5GB  104GB   15.7GB  logical   ext3
 9      104GB   120GB   15.8GB  logical   ext3

Model: MAXTOR 6L040L2 (ide)
Disk /dev/hdd: 40.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      32.3kB  2097MB  2097MB  primary  linux-swap   boot
 2      2097MB  32.7GB  30.6GB  primary  ext3
 3      32.7GB  40.0GB  7337MB  primary  ext3

Here are the steps leading to the failure:

Boot from DVD. Chose "Install system with basic video driver"
(The default path fails on hardware detection, but that's another matter).

Language: English
Keyboard: us
Installation Method: installation image is on Local CD/DVD
Media tested OK.

In Anaconda, I selected:

* Basic Storage Devices, Next.

I have two ATA drives and both were listed, looking correct.
I chose one. Next.

I entered the FQDN Hostname when prompted. Next.
Allowed default of New York time. Next.
Provided a root password. Next.

"Which type of installation would you like?"

I chose Create Custom Layout. This selected "Review and modify partitioning layout" for me. Next.

On the "Please Select a Device" pane, my drive looked correct.

I selected existing sda5 and clicked Edit.
In the dialog, I selected:
- Format as ext4
- Mount point: /
I clicked OK.

A dialog reported that the unexpected exception has occurred.
Comment 4 Chris Lumens 2010-04-22 13:06:25 EDT

*** This bug has been marked as a duplicate of bug 563526 ***
Comment 5 Alan Ernhart 2010-04-22 13:37:10 EDT
This defect was reproducible (e.g. it happened twice in a row). To get around it, I:

- Rebooted into the RHEL5 partition
- installed the package for ext4 support, then formatted the target partition, taking defaults:

mkfs -t ext4 /dev/hda5

I then rebooted into the DVD install and selected that partition and clicked Edit. Given that it was already formatted for ext4, I could have left the "Format as: checkbox cleared, but I selected it as in the failing case, then chose / as the mount point.

Upon clicking OK, I did NOT get the exception, so it appears to be an issue with the ext3 that had been on that partition. I can't be confident that the failure I experienced would happen with *any* other ext3 in such a disk layout or whether it was due to some corruption on my partition.

I plan to smoke-test some things on RHEL6 next, but might be able to circle back to this soon - reformatting to ext3 and trying again to repro the failing case here. In the meantime, what was likely a corner case has become more so here.
Comment 6 Vinny 2010-05-15 00:07:41 EDT
Created attachment 414206 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.