Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 584851 - dhclient package claims ownership to directories owned by filesystem package
dhclient package claims ownership to directories owned by filesystem package
Status: CLOSED DUPLICATE of bug 566751
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dhcp (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Jiri Popelka
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 11:05 EDT by Jonathan Billings
Modified: 2010-04-22 11:20 EDT (History)
0 users

See Also:
Fixed In Version: dhcp-4.1.1-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-22 11:19:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Billings 2010-04-22 11:05:17 EDT
Description of problem:
The 'dhclient' package claims to own:
/usr/lib64/pm-utils
/usr/lib64/pm-utils/sleep.d

However those are in the filesystem package as well, with different modes:

$ rpm -q --qf "[%{NAME} %{FILEMODES:octal} %{FILENAMES}\n]" \
  filesystem dhclient | egrep '/usr/lib64/pm-utils$'

filesystem 40555 /usr/lib64/pm-utils
dhclient 40755 /usr/lib64/pm-utils


$ rpm -q --qf "[%{NAME} %{FILEMODES:octal} %{FILENAMES}\n]" \
  filesystem dhclient | egrep '/usr/lib64/pm-utils/sleep.d$'

filesystem 40555 /usr/lib64/pm-utils/sleep.d
dhclient 40755 /usr/lib64/pm-utils/sleep.d


Version-Release number of selected component (if applicable):
dhclient-4.1.0p1-15.el6.x86_64
filesystem-2.4.30-2.1.el6.x86_64


How reproducible:
Occurs when you install the packages

Steps to Reproduce:
1. Install filesystem and dhclient packages
2. run 'rpm -V filesystem'
3.
  
Actual results:
$ rpm -V filesystem
.M.......    /dev
.M.......    /usr/lib64/pm-utils
.M.......    /usr/lib64/pm-utils/sleep.d

Expected results:
$ rpm -V filesystem
.M.......    /dev

(the /dev results is an unrelated bug with filesystem)


Additional info:
This bug negatively affects configuration management systems that rely on the package database's verification to ensure the validity of installed packages.  For example, bcfg2's Package managment marks the filesystem package as invalid.
Comment 1 Jiri Popelka 2010-04-22 11:19:13 EDT
Fixed in Version: dhcp-4.1.1-3.el6

*** This bug has been marked as a duplicate of bug 566751 ***

Note You need to log in before you can comment on or make changes to this bug.