Bug 584860 - kickstart.profile.system.getPartitioningScheme - does not return %include statements
kickstart.profile.system.getPartitioningScheme - does not return %include sta...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
540
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Garik Khachikyan
:
Depends On:
Blocks: sat54-errata 659469
  Show dependency treegraph
 
Reported: 2010-04-22 11:23 EDT by Aron Parsons
Modified: 2016-01-04 00:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the kickstart.profile.system.getPartitioningScheme() method did not return "%include" statements in the "partitions" section of Kickstart. With this update, the method has been corrected and returns "%include" statements as expected.
Story Points: ---
Clone Of:
: 659469 (view as bug list)
Environment:
Last Closed: 2010-12-16 10:45:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aron Parsons 2010-04-22 11:23:10 EDT
Description of problem:
The kickstart.profile.system.getPartitioningScheme() method filters out %include statements that are in the 'partitions' section of the Kickstart.  Since these lines are valid, they should not be filtered in the output from the API call.

Version-Release number of selected component (if applicable):
Satellite 5.3.0

How reproducible:
Always

Steps to Reproduce:
1. put an %include statement in the 'partitions' section of a Kickstart
2. use the kickstart.profile.system.getPartitioningScheme() method to get the contents of the 'partitions' section
  
Actual results:
%include lines are filtered out

Expected results:
%include lines should be returned since they are valid
Comment 1 Tomas Lestach 2010-07-20 05:47:12 EDT
getPartitioningScheme returns all partition sections now

spacewalk.git:
 b4a435b051e94a091b7fb77650f28f7909980ec3
 06ec96740de2c57173b40bef416c80eec38962aa
Comment 5 Garik Khachikyan 2010-12-07 10:31:13 EST
# VERIFIED

The following package(s) fixing the issue:
spacewalk-java-config-1.2.39-33.el5sat.noarch.rpm   
spacewalk-java-oracle-1.2.39-33.el5sat.noarch.rpm   
spacewalk-java-lib-1.2.39-33.el5sat.noarch.rpm   
spacewalk-taskomatic-1.2.39-33.el5sat.noarch.rpm   
spacewalk-java-1.2.39-33.el5sat.noarch.rpm

>>> server.kickstart.profile.system.getPartitioningScheme(token,'test-tbr')
['part /boot --fstype=ext3 --size=200 ', 'part pv.01 --size=1000 --grow ', 'part swap --size=1000   --maxsize=2000 ', 'volgroup myvg pv.01 ', 'logvol / --vgname=myvg --name=rootvol --size=1000 --grow', '%include test line 1']
Comment 7 errata-xmlrpc 2010-12-16 10:45:47 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0991.html
Comment 8 Jaromir Hradilek 2010-12-16 11:32:20 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the kickstart.profile.system.getPartitioningScheme() method did not return "%include" statements in the "partitions" section of Kickstart. With this update, the method has been corrected and returns "%include" statements as expected.
Comment 10 Tomas Lestach 2010-12-17 04:09:38 EST
Changing to Version 540 to distinguish the BZ from Bug 659469

Note You need to log in before you can comment on or make changes to this bug.