Bug 584868 - Kernel prevents Plymouth and X from starting
Summary: Kernel prevents Plymouth and X from starting
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-22 15:33 UTC by Peter Gückel
Modified: 2010-05-07 18:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-07 18:10:18 UTC
Type: ---


Attachments (Terms of Use)
The Xorg log of the previous session (that didn't work) (53.45 KB, application/octet-stream)
2010-04-25 03:49 UTC, Peter Gückel
no flags Details

Description Peter Gückel 2010-04-22 15:33:04 UTC
Description of problem:
When booting this kernel, there is no plymouth display and no X, although the system does boot. The screen is just all black without a mouse pointer. Switching to another virtual terminal shows the same black display. 'In the dark', I am able to type 'shutdown -h now' and the system does verily shut down. Using the old kernel (2.6.33.2-41.fc13.x86_64) works just fine. [I haven't tried the laptop, also intel, but i686, yet.]

Version-Release number of selected component (if applicable):
kernel-2.6.33.2-60.fc13.x86_64
kernel-2.6.33.2-57.fc13.x86_64
xorg-x11-server-common-1.8.0-7.fc13.x86_64
xorg-x11-server-Xorg-1.8.0-7.fc13.x86_64
plymouth-0.8.2-2.fc13.x86_64

How reproducible:
update and reboot using new kernel.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Peter Gückel 2010-04-23 17:04:34 UTC
I updated to mesa--7.8.1-2.fc13, but the problem persists unchanged. Using kernel-2.6.33.2-41.fc13 works, however, but not the newer ones.

Comment 2 José Matos 2010-04-24 11:12:37 UTC
I see this on two machines with an intel graphics card but not on my laptop with an ATI. I am not sure if this is the distinctive factor.

In my case the lcd display refuses to show any output claiming that frequency is out of range.

In both cases 2.6.33.2-41 works but 2.6.33.2-57 fails.

Should I add other information like the lspci output to this bug?

Comment 3 Peter Gückel 2010-04-25 03:49:29 UTC
Created attachment 408913 [details]
The Xorg log of the previous session (that didn't work)

I don't understand much of this file, but I compared it to the one that does work and the good one (using old kernel) ends with the modelines, while this one has the tailing lines where it appears that AIGLX and all the modules are mysteriously shut down at the end of the startup phase.

Comment 4 Peter Gückel 2010-04-25 03:53:24 UTC
I should also add that I now updated the laptop (Intel Mobile 915GM/GMS/910GML Express) and it works just fine with the 2.6.33.2-57 kernel.

Yet, the desktop (Intel X3000 Chipset 965G) does not have any X using that kernel, only with the older 2.6.33.2-41 one.

Comment 5 Peter Gückel 2010-04-26 23:40:00 UTC
I just upgraded to xorg-x11-server-*-1.8.0-8.fc13.x86_64 and there is no change on x86_64 with kernel-2.6.33.2-57. It still only works with the older kernel.

Comment 6 Adam Jackson 2010-04-27 13:36:21 UTC
Boot to runlevel 3 (append the number '3' by itself to the kernel command line) and try to run X by itself with 'X -retro'.  If that launches and stays up, then this is your desktop session crashing, not X's fault.  You can terminate the -retro server with control-alt-backspace.

Comment 7 Peter Gückel 2010-04-28 01:55:37 UTC
Maybe I hadn't made myself clear: after grub runs, the screen goes black for a few seconds with a cursor flashing about 1/4 of the way down the screen at the left margin. At this point, normally Plymouth takes over and the screen turns blue. Well, running the 2.6.33.2-57+ kernels, instead of Plymouth kicking in and turning the screen blue, all goes totally black (including the flashing cursor, which now disappears) and my monitor spits out a message that says 'No Signal', but in the background, I can hear my drive working and it's light is avtive, and when it all stops, I am able to log in (on a different virtual terminal) 'in the dark', as I cannot see a thing and am able to restart the computer by typing 'shutdown -h now'.

(In reply to comment #6)
> Boot to runlevel 3 (append the number '3' by itself to the kernel command line)
> and try to run X by itself with 'X -retro'.  If that launches and stays up,
> then this is your desktop session crashing, not X's fault.  You can terminate
> the -retro server with control-alt-backspace.    

Nevertheless, I tried what you suggested. The screen goes black instead of Plymouth appearing and I can hear the drive working during the run level 3 boot process. When all had settled down,, 'in the dark', I typed 'X -retro' and verily something happened, as I could hear the drive working and the drive light flashed, but the screen remained totally black. I switched to a different virtual terminal and logged in 'in the dark' and shut the computer down with the shutdown command.

Comment 8 José Matos 2010-04-28 07:27:21 UTC
As the original reporter the oldest graphics card is working now.

In the other card even after passing the 3 argument to the boot sequence I get a warning on the lcd display saying:

frequency out of range: 16 KHz / 15 Hz
Please change the display mode to 60Hz

Comment 9 Peter Gückel 2010-04-28 17:12:55 UTC
(In reply to comment #8)
> As the original reporter the oldest graphics card is working now.
> 
Sorry, bud, but I am the original reporter. My name is shown in the upper right of this page.

Yes, here, too. The older Intel card (in the laptop) works, while the newer one (in the desktop) does not work with kernels 2.6.33.2-57+.

Comment 10 José Matos 2010-04-29 08:09:03 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > As the original reporter the oldest graphics card is working now.
> > 
> Sorry, bud, but I am the original reporter. My name is shown in the upper right
> of this page.

The verb was missing in the sentence above, "As the original report said"...

Comment 11 Peter Gückel 2010-04-29 17:55:14 UTC
The '73' kernel does not fix anything.

Comment 12 Peter Gückel 2010-05-03 14:21:37 UTC
The '78' kernel does not work. The monitor displays 'No Signal' as soon as plymouth kicks in, same as in all the kernels since '41'.

Comment 13 Peter Gückel 2010-05-05 17:00:33 UTC
kernel-2.6.33.3-79.fc13.x86_64 does not work (I have updated to the newest intel driver, mesa, etc). There is still 'No Signal' and just a black screen. The only kernel that still works is kernel-2.6.33.2-41.fc13.x86_64.

Comment 14 Peter Gückel 2010-05-07 00:43:25 UTC
I should add that I exchanged motherboards 2 days ago. As a consequence, I no longer have INTEL X3000 (Chipset 965G) graphics. I now have Intel 4 Series Chipset Integrated Graphics.

The problem remains unchanged, tested up to kernel-2.6.33.3-79.fc13.x86_64.

I am still, despite the more recent graphic chip, only able to use kernel-2.6.33.2-41.fc13.x86_64.

Comment 15 José Matos 2010-05-07 16:33:14 UTC
After updating to the latest updates-testing kernel-2.6.33.3-85.fc13.x86_64 works for me.

It is the first after -41 that boots correctly.

Thanks.

Comment 16 Peter Gückel 2010-05-07 17:54:19 UTC
I don't know if this is helpful, but my old motherboard had a VGA output and my monitor is analog; my new motherboard has a DVI output with a VGA adaptor, so I can use the same analog monitor. The problem, as noted in the previous comment remains.

I just installed kernel-2.6.33.3-85.fc13.x86_64, so I will reboot and see what happens.

Comment 17 Peter Gückel 2010-05-07 18:10:18 UTC
Holy moley! It was a slow train coming, but it works. Case closed. Basta!


Note You need to log in before you can comment on or make changes to this bug.