Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 584897 - [RFE] compact results view
[RFE] compact results view
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Raymond Mancy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 12:49 EDT by Ales Zelinka
Modified: 2014-12-07 20:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 03:00:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2010-04-22 12:49:43 EDT
Description of problem:
Results are no longer structured into levels as were in RHTS: job -> recipe -> task. When job results are opened, all information from job id to the least significant debug log attached to some unimportant task are visible. 

Compare these two jobs - same setup, one in rhts one in beaker:

RHTS (un-fold the recipe)
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=151215&type=single

BEAKER
https://beaker-stage.app.eng.bos.redhat.com/jobs/527

The one from beaker is 3 times longer and contains lots of task-run details that are not important for general overview of a run.

Now imagine scenario with 5 recipes, each around 160 tasks, many of those tasks having subtests (a.k.a BaseOS QE TestTiers). That would be one helluva result page.

RHTS had this solved pretty well with different levels of details

1)recipe overview - to quickly spot which machine aborted, which is still running,... RHTS: http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=151215&type=single

2) recipe details - task results - list of tasks with results & score (and maybe times), nothing more. To quickly find particular task and its results RHTS: the above link after clicking the triangle

3) task details - log, attachments, all available info. For debugging purposes. RHTS:  http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=13691896

I wouldn't mind if the different detail level were implemented using some modern html/javascript magic  if all levels remain linkable (for example #2 is not in RHTS)


Thanks
Comment 1 Bill Peck 2010-04-24 10:23:30 EDT
I've made some changes on beaker-stage that incorporate some of the things you mention.  Can you look and see if that is a step in the right direction?

Just so you know, People complained about the levels that they had to open in the old rhts.  

Hopefully I can strike some middle ground where everyone is somewhat happy.
Comment 2 Kevin Baker 2010-04-25 20:56:03 EDT
I think it will be hard to make everyone happy. How about letting users set preferences so their default view unrolls as they like?
Comment 3 Ales Zelinka 2010-04-26 05:06:13 EDT
I agree.  (In reply to comment #1)
> I've made some changes on beaker-stage that incorporate some of the things you
> mention.  Can you look and see if that is a step in the right direction?

It is, thanks. The new collapsed recipe view corresponds to view#1 from comment#0
> 
> Just so you know, People complained about the levels that they had to open in
> the old rhts.  

I see. Than there probably isn't one result page layout to satisfy all users and I'd go with the configurable level of details Kevin mentions:

 * levels of details as described in comment#0

 * default level configurable via preferences

 * controls on result page - the ones currently present (per-recipe) and a global one - expanding/collapsing all recipes at once

 * level of details embedded in URL so that links can be sent for a particular detail level
 

What do you think?
Comment 4 Bill Peck 2010-05-26 13:21:34 EDT
I haven't had any complaints since the new layout change.  and Today's update loads the task results as an ajax call, this should resolve the performance issues.


Can I close this?
Comment 5 Ales Zelinka 2010-06-22 12:26:40 EDT
The non/all detail level are satisfied by collapsing/expanding individual recipes of a job. And for the intermediate level of details (view#2), matrix report (that is, by the way, absolutely awesome) can be used.

Only two minor [RFE] remains:

 - global "[hide|show] [all|failed] results" buttons that will work on all the recipes at once
 - link the matrix report from job result page (even though one job matrix report probably isn't the major use-case for it, it still is very useful) 

Should I file those as separate RFEs?

Thanks
Comment 6 Raymond Mancy 2010-08-03 03:00:58 EDT
Ales, Sorry for the very delayed response. If you could file these as seperate RFE's that would be great.

Note You need to log in before you can comment on or make changes to this bug.