Bug 5849 - Installer Crashes
Installer Crashes
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-11 19:31 EDT by nweeks
Modified: 2015-01-07 18:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-21 16:14:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nweeks 1999-10-11 19:31:22 EDT
This is difficult..
Installing onto a dual celeron 366, 128mb ram, 6.4gb
quantum, 24X pioneer cd.
Boot from cd, expert or normal mode, chose custom
installation, chose mouse, partitioned drive, made root(/),
and 100MB swap.

Clicked next, and Xwindows shuts down, and machine reboots.
X comes up with an error message saying,
Can't open SecurityPolicy or something like that.

Video card - Rendition Verite 2x00, (SVGA xserver)

Hope I haven't annoyed anyone.

Nigel
Comment 1 Jay Turner 1999-10-21 13:16:59 EDT
Try installing in text mode (type "text" at the boot prompt) and see
whether the same thing happens, and if it does, then send me the error
message.  The message that you are seeing about SecurityPolicy is
actually a red herring and has nothing to do with the problems which
you are seeing.

------- Additional Comments From   10/25/99 00:27 -------
I have the same problem with a riva tnt2 dual xenon machine. the
installer crashes at exactly the same point. Works on a dell up with
a mac64 card just fine. I will try the text mode install.

Brian

------- Additional Comments From   10/25/99 01:50 -------
Brian again. Fails in text mode as well in exactly the dame place. I
think it's somthing like sig11 failure "you can now safely reboot
your system. I went into expert mode, did not load any drivers (I
have a adaptec scsi onpoard) and I am able to install to my ide drive.

dual xenon asus mb
789x uw scsi on board
256mb ram
riva tnt2 ultra (32m)
quantum fireball ide
3 scsi drives

Brian

------- Additional Comments From   11/01/99 13:12 -------
I have the same problem on my machine.  I have tried graphical and
text.  Once it probes the card it reboots with the error mentioned
above.
233mmx
v3 2000
Comment 2 keithj69 1999-11-02 09:13:59 EST
Ok fixed it.  Did 2 things.  First used newest boot image, and second
my network card and video card were trying to use the same irq.
Reconfigured my net card in dos and then on the install did a
custom.  From there it was smooth sailing.
Suggestion:  If you still have windows on a partion check the irq's
and I/O's Of your vid card and anything else.
Comment 3 sturmann 1999-11-25 14:47:59 EST
I have the same problem. The installer crashes with sig11 in text mode and
'error opening security policy file' in expert mode at exactly the same place.
The difference is that I have used, I believe, the latest boot image
(boot-1999-044.img).
Also, I have a scsi Zip drive which works fine with an olderSlackware machine,
but now, in expert mode, when I specify the parameters for the 152x module it
complains that the IT # is probably wrong but it is OK.

Any suggestion?
Comment 4 edegraaf 2000-01-17 16:59:59 EST
I uninstalled Red Hat 6.1 (the rpm's from KDE detroyed my X-windows after
uninstalling) This bug sounds like the problem I have. Maybe a millenium bug?!
Because before 2000 I reinstalled Linux multiple times.
Mine computer:
PPro 400, 6.4 and 8.4 GB hard-drives, mach64 video card, sound blaster PCI 128
and 128 MB memory

I also tried text mode. Same problem, I get something like:'Security Policy'
Comment 5 Jay Turner 2000-02-08 13:04:59 EST
The "SecurityPolicy" error message that everyone is reporting is a red herring.
It is merely telling the user that the Xwindows system is not able to
authenticate the user who has brought it up . . . this makes sense considering
that you are performing an installation and therefore there are no users.  What
media are people installing from?  Sounds like there are some bad permissions
which are causing the installer to not be able to read in the necessary files.

Can anyone shed a light on things here?  The only other thing that I can imagine
is hardware conflicts.  How about trying out the latest version of RawHide and
see whether you continue to have problems.
Comment 6 nweeks 2000-02-08 17:06:59 EST
I found that installing to partitions on other than the first drive may have
contributed to this problem. On several tests, installing to /dev/hdb, a
reference to some file had one to many /'s in is, resulting in an X crash.  I
just installed to the /hda, and it works repeatedly ok.

WARNING - this may just be an isolated coincedence, and not the solution to all
the issues here.

Nigel (The cause of this bug train)

Note You need to log in before you can comment on or make changes to this bug.