Bug 584909 - Software Add / Remove option errors out
Software Add / Remove option errors out
Status: CLOSED DUPLICATE of bug 582950
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
All Linux
low Severity high
: rc
: ---
Assigned To: Dennis Gregorovic
Release Test Team
Depends On:
  Show dependency treegraph
Reported: 2010-04-22 13:21 EDT by Rajagopal Ramamoorthy
Modified: 2010-06-17 17:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-04-22 23:13:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rajagopal Ramamoorthy 2010-04-22 13:21:40 EDT
Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 821, in get_categories
    cats = self.yumbase.comps.categories
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 755, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 712, in _getGroups
    raise Errors.GroupsError, _('No Groups Available in any repository')
GroupsError: No Groups Available in any repository
Comment 2 RHEL Product and Program Management 2010-04-22 16:13:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
Comment 4 Dennis Gregorovic 2010-04-22 18:15:15 EDT
Looks like a couple different issues going on.

First, there's a bug in either yum or PackageKit, depending on how you look at it.  The lack of comps data should not cause a traceback in PackageKit.  So, either yum shouldn't throw the error or PackageKit should catch it.

Second, there _is_ comps data in the Beta 1 repos, so I don't know why yum isn't finding them here.  What's the output of "yum repolist"?
Comment 5 Rajagopal Ramamoorthy 2010-04-22 18:25:24 EDT
Unfortunately, I no longer have the RHEL 6 BETA available on my m/c. Had to revert back to RHEL 5.5.  The reported error popped up in a dialog when Add / Remove Software menu option is clicked. It does not prevent us from viewing other packages available. So some listing does occur.  But yum update or yum install failed consistently to fetch any item from ftp site. This install was for 64 bit version of RHEL 6 developer workstation done using the dvd iso image.
Comment 6 Dennis Gregorovic 2010-04-22 23:13:10 EDT

*** This bug has been marked as a duplicate of bug 582950 ***

Note You need to log in before you can comment on or make changes to this bug.