Bug 584919 - [r100] switch to 800x600 results in black screen
Summary: [r100] switch to 800x600 results in black screen
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 547598 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-22 17:57 UTC by Dan Williams
Modified: 2010-09-06 16:58 UTC (History)
7 users (show)

Fixed In Version: kernel-2.6.34.6-47
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-06 16:58:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DRM debug log of modeswitch to 800x600 (122.14 KB, text/plain)
2010-04-22 18:00 UTC, Dan Williams
no flags Details
Xorg switches back to 1024x768 after the confirmation timeout (122.79 KB, text/plain)
2010-04-22 18:03 UTC, Dan Williams
no flags Details
X log of the resolution switch and switch back (113.40 KB, text/plain)
2010-04-22 18:04 UTC, Dan Williams
no flags Details
startup dmesg log (38.82 KB, text/plain)
2010-04-22 18:05 UTC, Dan Williams
no flags Details

Description Dan Williams 2010-04-22 17:57:25 UTC
Resolution switching hasn't worked on my Thinkpad T42 with a radeon mobility 7500 since early F12.

Comment 1 Dan Williams 2010-04-22 18:00:02 UTC
Linux prettyboy 2.6.33.1-24.fc13.i686 #1 SMP Tue Mar 30 18:49:12 UTC 2010 i686 i686 i386 GNU/Linux

xorg-x11-server-Xorg-1.8.0-4.fc13.i686
libdrm-2.4.20-1.fc13.i686
xorg-x11-drv-ati-6.13.0-0.23.20100219gite68d3a389.fc13.i686

Comment 2 Dan Williams 2010-04-22 18:00:58 UTC
Created attachment 408398 [details]
DRM debug log of modeswitch to 800x600

Comment 3 Dan Williams 2010-04-22 18:03:36 UTC
Created attachment 408400 [details]
Xorg switches back to 1024x768 after the confirmation timeout

Comment 4 Dan Williams 2010-04-22 18:04:12 UTC
Created attachment 408401 [details]
X log of the resolution switch and switch back

Comment 5 Dan Williams 2010-04-22 18:05:17 UTC
Created attachment 408402 [details]
startup dmesg log

Comment 6 Dan Williams 2010-04-22 18:08:03 UTC
When you select the new resolution and hit Apply in the Monitors capplet, the screen goes black, the backlight goes off, then quickly comes back on, but the panel stays black.  Hitting ESC or waiting for the confirmation dialog to timeout brings me back to 1024x768 which is the native panel resolution and everything is fine.

Comment 7 Jérôme Glisse 2010-04-23 13:12:43 UTC
Dan can you attach Xorg log with UMS please ? (nomodeset=1 on kernel boot line)

Comment 8 Jérôme Glisse 2010-04-30 18:47:42 UTC
Dan please confirm that kernel :
http://koji.fedoraproject.org/koji/taskinfo?taskID=2150310

Fix the issue for you too.

Comment 9 Dan Williams 2010-07-21 14:44:30 UTC
*** Bug 547598 has been marked as a duplicate of this bug. ***

Comment 10 Dan Williams 2010-07-21 14:46:31 UTC
Darn, didn't see the scratch build in time...  I'm currently running 2.6.33.6-147.fc13.i686 and it's still not fixed there.

Could you do another scratch build wtih whatever patch you had in that kernel and I'll retest now that I have the hardware again?

Comment 11 Dan Williams 2010-07-21 14:47:58 UTC
Again, the following packages still don't work:

kernel-2.6.33.6-147.fc13
xorg-x11-server-Xorg-1.8.2-1.fc13
xorg-x11-drv-ati-6.13.0-1.fc13

Comment 12 Chuck Ebbert 2010-07-22 12:53:14 UTC
Please try 2.6.34.1-20 from koji

Comment 13 Dan Williams 2010-07-22 17:05:37 UTC
Hot damn that works.  Thanks!

Comment 14 Chuck Ebbert 2010-07-23 00:03:47 UTC
We don't close the bug until the kernel is released, we just mark it modified. That makes it much easier to see which bugs are going to be fixed with the next release.


Note You need to log in before you can comment on or make changes to this bug.