Bug 584923 - Severe display distortion with xorg-x11-drv-intel-2.11.0-1.fc13.i686
Summary: Severe display distortion with xorg-x11-drv-intel-2.11.0-1.fc13.i686
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-22 18:08 UTC by Anne
Modified: 2011-05-03 08:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-03 08:21:31 UTC
Type: ---


Attachments (Terms of Use)
Screenshot (12.29 KB, image/png)
2010-04-22 18:08 UTC, Anne
no flags Details
Hardware info from lspci -vv (28.97 KB, text/plain)
2010-04-22 18:13 UTC, Anne
no flags Details

Description Anne 2010-04-22 18:08:08 UTC
Created attachment 408404 [details]
Screenshot

Description of problem: Desktop widgets and the panel are severely distorted, having horizontal black/white lines throughout.  The lines on the panel are broken, so labels can be read with difficulty.  Applications don't seem to be affected.  Compositing is turned off, as I have not yet managed to get a good display with this GPU.  However, the previous driver version did not have this problem.


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.8.0-7
xorg-x11-drv-intel-2.11.0-1

How reproducible:
Constant

Steps to Reproduce:
1.Carry out standard yum upgrade
2.
3.
  
Actual results:
Distortion of display

Expected results:
Improved display

Additional info:

Comment 1 Anne 2010-04-22 18:13:33 UTC
Created attachment 408405 [details]
Hardware info from lspci -vv

Comment 2 Elad Alfassa 2011-05-03 05:07:45 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Anne 2011-05-03 08:13:24 UTC
I regret that I am unable to do this as I no longer have any instance of Fedora 13.  I can confirm that I have worked with Fedora 14 without problems, but I cannot give any version number for when the problem disappeared.

Comment 4 Elad Alfassa 2011-05-03 08:21:31 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.