Bug 58494 - box hangs on poweroff when smp kernel is used
box hangs on poweroff when smp kernel is used
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-17 22:19 EST by m-herron
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 20:25:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description m-herron 2002-01-17 22:19:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; MSOCD)

Description of problem:
I have a RH 7.2 box.  It has all the latest patches, including the latest 
kernel.  When I am running the smp kernel, the machine hangs when I try to shut 
it down.  Namely, I get the "Power Down" message and then it hangs.  This 
happens even when apm is not running (which it never does on my workstation).  
It never happens when I run the single processor kernel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot machine with smp kernel
2.log in
3.poweroff or shutdown -h now
	

Actual Results:  The machine hangs at "Power Down."  Then I turn it off by hand 
(not a good solution!)

Expected Results:  The machine should have turned off itself.

Additional info:

THe machine is a Dell Precision 530 with 2 xeon 1.7g processors.
Comment 1 Arjan van de Ven 2002-01-18 13:08:35 EST
Ah. Automatic poweroff is disabled by default on SMP machines because power off
requires APM bios services, and the 1) vast majority of SMP bios writes don't
know how to spell APM and 2) APM is not SMP safe by design.

There is an override where you can tell the kernel that you trust your bios,
just append the text

apm=power-off

to the "vmlinuz" line in the /boot/grub/grub.conf
Comment 2 m-herron 2002-01-21 15:53:53 EST
Sorry, but this did not work.  The machine still hangs when you add the line you suggested to grub.conf

Michael
Comment 3 John Bage 2002-07-02 16:53:09 EDT
I am having the same problem using KDE and Grub on RedHat Linux 7.3. I have 
even tried to do all the updates and even a complete reinstall of it but with 
no luck. It still continues to do this. I have also tried the bigmem, smp, and 
the regular kernels and the same problem still continues.
Comment 4 Alan Cox 2003-06-07 20:25:16 EDT
If the BIOS lacks APM power off then we can't do anything about it

Note You need to log in before you can comment on or make changes to this bug.