Bug 584940 - 2.8: Quicksearch custom fields and other enhancements
2.8: Quicksearch custom fields and other enhancements
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.4
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks: JIRABZ
  Show dependency treegraph
 
Reported: 2010-04-22 14:55 EDT by David Lawrence
Modified: 2013-06-23 23:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 17:34:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to allow simple keyword search of custom text fields (v1) (1.05 KB, patch)
2010-05-07 13:59 EDT, David Lawrence
dkl: review? (nelhawar)
Details | Diff

  None (edit)
Description David Lawrence 2010-04-22 14:55:44 EDT
JIRA Requirement 2.8:

Currently the bugzilla Bugzilla::Search::QuickSearch module which constructs the necessary SQL for
performing searches on the Bugzilla database, only searchs the following fields for text keywords:

 * Summary
 * Keywords
 * Product
 * Component
 * Status Whiteboard. 
 * If a word looks like a part of a URL, that field is included in the search, too. 

You can however search most of the core Bugzilla fields (status, version, flags, groups, severity, etc.) by using field:string formatted search terms. 
Custom fields are not yet searchable from quicksearch.

Also certain feature requests made in Bugzilla should be considered as well for inclusion such as showing previous quick search text in the field in buglist.cgi, etc.

Proposed Solution(s): 

Update Bugzilla::Search::QuickSearch to also include text type custom fields in the basic keyword search. Also to include the ability
to search on customfield:value search pairs as well similar to the other bug fields.
Comment 1 David Lawrence 2010-05-07 13:59:03 EDT
Created attachment 412414 [details]
Patch to allow simple keyword search of custom text fields (v1)

Patch to Bugzilla/Search/QuickSearch.pm that allows searching of keywords in custom fields that are either free text or text area types.

Please review
Dave
Comment 2 Noura El hawary 2010-05-10 06:53:26 EDT
Hi Dave,

I applied your patch to bz-web1, trying to test it, but it is not working for me,unless i am doing something working, always getting the error:


Field cf_environment is not a known field. The legal field names are listed here. 

for example when I search for "cf_environment:test"

and then when i click on listed here it brings a list of all possible fields, maybe a good idea to add this list the text field types of the custom fields.

Thanks,
Noura
Comment 3 Max Kanat-Alexander 2010-05-26 17:48:20 EDT
Note that Bugzilla 3.6 already fully supports quicksearching of custom fields, in addition to various other nice quicksearch enhancements (including greatly improved documentation).
Comment 4 David Lawrence 2010-05-27 17:34:54 EDT
Yeah noticed that now after doing the changes for 3.4. We can scratch this requirement.

Note You need to log in before you can comment on or make changes to this bug.