Bug 584944 - 1.1.14: Richer bug relationships
1.1.14: Richer bug relationships
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.6
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
Lukáš Petrovický
contractor
:
Depends On:
Blocks: JIRABZ
  Show dependency treegraph
 
Reported: 2010-04-22 15:00 EDT by David Lawrence
Modified: 2014-10-12 18:46 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-20 00:26:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 537749 None None None Never

  None (edit)
Description David Lawrence 2010-04-22 15:00:54 EDT
JIRA Requirement 1.1.14:

JIRA currently supports several different issue linking features such as blocks, depends on, related to and relates to, incorporated by, incorporates, 
and duplicates and duplicated by. 

Bugzilla currently supports blocks and depends on fully, and partially supports duplicated by and duplicates. Duplicates is a one-to-many relationship and
not a many-to-many relationship like JIRA. This means that BugA can be a closed as a duplicate of BugB but not a duplicate of BugC. But BugB can also
be duplicated by other bugs as well such as BugD and BugE. 

Bugzilla has a feature called "See Also" which could be used to partially implement relates to and related to but was originally meant to reference other
bugs outside of the current Bugzilla installation and not really to bugs internally. This also means there is not a two way relationship similar to 
blocks and depends on. If BugA is added to the "See Also" field of BugB, BugA does not know anything about the relationship and does not display the
relationship in it's own bug view.

Proposed Solution(s):

Implement new generic mapping table storing related to and relates to information along with current depends on and blocks and update the web UI to 
allow managing these values (upstream bug 12286 has old patch). The mapping table should allow for adding new relationships in the future by adding
a type column that designates what type of mapping it is. For duplication, I feel we can just convince the JIRA team to adopt the current method in 
Bugzilla as it has not been a problem in the past for Bugzilla users. As for incorporates and incorporated by, we need to research how much this is 
really used and what exactly does it mean. It may be that the field is redundant and not needed.
Comment 1 David Lawrence 2010-05-11 16:09:42 EDT
Newer upstream bug where this is being discussed currently:

https://bugzilla.mozilla.org/show_bug.cgi?id=537749
Comment 2 Max Kanat-Alexander 2010-05-26 17:40:18 EDT
  Okay. If we don't need the incorporation relationships, couldn't we just make See Also two-way for the local installation, and allow it to take raw bug ids for the local install, and thus solve all the existing relationships?
Comment 3 David Lawrence 2010-05-27 17:47:50 EDT
(In reply to comment #2)
>   Okay. If we don't need the incorporation relationships, couldn't we just make
> See Also two-way for the local installation, and allow it to take raw bug ids
> for the local install, and thus solve all the existing relationships?    

I will have to run it by the JIRA guys. I know they sometimes want to map a single issue as a duplicate of multiple other issues but not sure if that is a
hard requirement. We cant do that currently in BZ that I know if.

But I could definitely see using the See Also field to have it detect that you put in a single id instead of a URL and assume it is a local bug report and link it differently (two way, maybe even show bug info like summary, status, etc.)

Dave
Comment 4 David Lawrence 2010-06-25 14:04:21 EDT
Let's just say the multiple duplicates is a no-go right now. So for this bug we will need a requirement to have the See Also field take either external bug addresses (one-way only for now) and also individual bug id's which need to be two way. So if the user enters a integer value (non-url) it is assumed it is a local bug report. The bug being referenced will also need to show the relationship as well. I would also say that at this time no notifications to the other bug are needed when attributes change on a parent bug. For example with dependencies when status changes the dependent bugs are also notified. We do not need that at this time. The user just needs to see the list of bugs that the current bug is related to in the UI.

Dave
Comment 5 Mike Harvey 2010-10-11 14:49:07 EDT
Assigned to Trevor to verify/QA.  https://bz-web2-test.devel.redhat.com/

JIRA issues with dependencies on other issues within the same product (or other products already migrated) should have similar dependencies in the newly created bug reports. Also JIRA issues that were related to other JIRA issues should now show up in the See Also Bugzilla field.
Comment 6 Mike Clark 2010-10-20 10:08:27 EDT
I see a case that "Depends On" are transferred, but not "See Also" such as for bug 635312.

I do see that "See Also" was migrated from "related" on bug 635136. But, in that case, there was no "dependency" on the jira.
Comment 7 Max Rydahl Andersen 2010-10-21 07:13:38 EDT
I haven't been able to find an issue where these links are present.

i.e. https://bz-web2-test.devel.redhat.com/show_bug.cgi?id=637942 does not have any reference to JBIDE-7058 as is the case on https://jira.jboss.org/browse/JBDS-1318

Another worthy comment is that in jira issues are hyperlinked by just mentioning them (see the JBDS-1318 jira comments) - that does not seem to happen in bugzilla (or at least I don't know the syntax for doing so)
Comment 8 Max Rydahl Andersen 2010-10-25 07:53:31 EDT
assigning back to dev.
Comment 9 David Lawrence 2010-10-28 14:18:42 EDT
(In reply to comment #7)
> I haven't been able to find an issue where these links are present.
> 
> i.e. https://bz-web2-test.devel.redhat.com/show_bug.cgi?id=637942 does not have
> any reference to JBIDE-7058 as is the case on
> https://jira.jboss.org/browse/JBDS-1318

The technical reason would be that since we did not migrate JBIDE to bz-web2-test.devel.redhat.com yet (and not sure it's even on the list), then the link didn't happen as the other bug does not exist in Bugzilla. 

I think for the next migration, when I encounter a link that one side is not in Bugzilla, then I will create the link instead in the External Bugs section and not the See Also. We will use See Also for local relationships and use External Bugs for external relationships.

Any comments?

> Another worthy comment is that in jira issues are hyperlinked by just
> mentioning them (see the JBDS-1318 jira comments) - that does not seem to
> happen in bugzilla (or at least I don't know the syntax for doing so)

Still to be implemented, on the blocker list.

Dave
Comment 10 David Lawrence 2010-11-05 14:49:12 EDT
Ok, I have updated the See Also code to allow local links to show status and bug summary when the mouse pointer hovers over them. Also I added (local) so that it is easier to tell which ones are local and which are not. Please take a look. Here are some bugs with examples to look at:

https://bz-web2-test.devel.redhat.com/show_bug.cgi?id=631806
https://bz-web2-test.devel.redhat.com/show_bug.cgi?id=631837
https://bz-web2-test.devel.redhat.com/show_bug.cgi?id=632820

Dave
Comment 11 Max Rydahl Andersen 2010-11-08 04:18:55 EST
David, I looked and all three examples and I'm not following where I'm supposed to look/hover ?

Care to make a screenshot and point it out to blind me ?
Comment 12 David Lawrence 2010-11-24 09:26:30 EST
(In reply to comment #11)
> David, I looked and all three examples and I'm not following where I'm supposed
> to look/hover ?
> 
> Care to make a screenshot and point it out to blind me ?

If the link in the See Also section has (local) next to it, then if you hover over the link, it will have a title window pop up showing the current status and summary of the linked bug report.

I will create a screenshot showing this soon.

Dave
Comment 15 trev 2010-12-16 11:01:43 EST
I'm afraid my eyesight matches Max's I've hovered all round the see also area in those 3 examples and see nothing.
Comment 16 Simon Green 2011-02-23 07:39:58 EST
Hi guys,

I'm marking this as ON_QA, as I think this needs some testing to see if this functionality is now working as required. All the URLs mentioned above are no longer valid, since they would have changed with the latest import.

Just a note that today's import was done by project so links from one project (e.g. BRMS) won't show dependancies with a different project (e.g. SOA), but issue of the same project will contain the correct links .

Please let me know of any cases of incorrect links from this import.
Comment 17 Len DiMaggio 2011-03-09 13:09:54 EST
Clean-up task from the March 9 2011 Bugzilla / BRMS Pilot Meeting

This bugzilla has been marked as ON_QA - we need to verify that the changes made to https://bz-web2-test.devel.redhat.com/ are acceptable and that this bugzilla can be closed. Please verify the change and close (or re-open) this bugzilla by March 15 2011. Thx!
Comment 18 Lukáš Petrovický 2011-03-10 09:39:24 EST
- JIRA BRMS-538 is cloned from BRMS-519. Neither one of the respective bugzillas  has a reference to the other (except for in comments).
- The same goes for BRMS-535, which doesn't even reference the JIRAs in comments.

Sending back to ON_DEV.
Comment 19 Lukáš Petrovický 2011-03-10 09:40:25 EST
And changing the assignee and QA contact.
Comment 31 Lukáš Petrovický 2011-04-20 02:53:56 EDT
Thanks simon, I consider this resolved.

Note You need to log in before you can comment on or make changes to this bug.