Bug 584951 - 3.3, 3.12: Enhanced reporting similar to reports currently generated by JIRA
Summary: 3.3, 3.12: Enhanced reporting similar to reports currently generated by JIRA
Status: CLOSED WONTFIX
Alias: None
Product: Bugzilla
Classification: Community
Component: Reporting/Charting   
(Show other bugs)
Version: 3.6
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords:
Depends On: 587798
Blocks: JIRABZ
TreeView+ depends on / blocked
 
Reported: 2010-04-22 19:12 UTC by David Lawrence
Modified: 2013-06-24 02:07 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-09 04:28:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Lawrence 2010-04-22 19:12:18 UTC
JIRA Requirements: 3.3, 3.12

Bugzilla equivalents are needed similar to the calendar and charting plugins available in JIRA. These allows to take any search result and view various statistics on it and planning schedules.
JIRA has reports such as Roadmap which shows bugs per target release and the percentage of completion. The calendar plugin uses the time estimates field in JIRA to create a calendar display
of when issues or products are due to be completed.

There are some third party tools internal to Red Hat which takes Bugzilla data and matches up to product schedules to show progress and workload but may not be flexible enough or 
useful for those outside of Red Hat.

Proposed Solution(s):

Update Bugzilla's built in reporting tools to generate views similar to JIRA showing roadmaps, calendars, etc. Can be integrated with the product browser.

Comment 1 Chris Ward 2010-12-01 11:53:00 UTC
Please loop llim and myself in (ie, QE) if any movement towards an integrated charting / reporting / calendaring tool is made. Platform QE (among other teams) have vested interests in functionality of this sort as well.

Thanks!

Comment 3 David Lawrence 2010-12-01 13:35:10 UTC
(In reply to comment #2)
> Also, could WAIDH be of any use?
> 
> http://git.engineering.redhat.com/?p=users/mbacovsk/waidh.git;a=summary
> 
> https://waidh.lab.bos.redhat.com/

Could be. I had forgotten about the tool and it could be useful for the JIRA folks until proper dashboard functionality exists in Bugzilla.

Dave

Comment 6 Simon Green 2011-02-23 13:30:26 UTC
Does the graphing part of this issue relate to the changes in bug 584949. If not, what other information is required?

Once I know that bug 584949 is working correctly, I can work on the calendar feature.

  -- simon

Comment 7 Mike Harvey 2011-03-23 13:29:29 UTC
Note:  The original requirement was marked as "Medium", therefore, by defination, it is not required for the Migration to proceed.  However, this is a good feature request and can be implemented post migration.  See 3.3 and 3.12: https://engineering.redhat.com/trac/bugzilla/wiki/JiraMigrationRequirements

Looks like Max Andersen helped define this requirement.  Also, it may be the case that Harvester will satisfy this feature request...or some combination of Harvester and bz reports/queries.  https://harvester-stage.englab.nay.redhat.com/

Comment 8 Max Rydahl Andersen 2011-03-31 11:17:33 UTC
The intent was that you could take a query result and use as input to a graphing tool since the graphs just operate on a set of issues anyway.

Harvester looks nice but seem to be limited/focused on very specific queries.

waidh.lab - I loaded the page, but didn't grok how that relates to this ?

Anyway, with bugzilla reports bound to be simply product issues linking back to org stuff there won't be much data to query for anyway and won't be giving much sensible info anyway and this issue in itself not a blocker as Mike points out.

Comment 9 Jeff Fearn 🐞 2012-05-30 04:46:26 UTC
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.

Comment 10 Jeff Fearn 🐞 2012-05-30 04:46:27 UTC
As part of the recent Bugzilla 4.2 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.

Comment 11 Jeff Fearn 🐞 2012-07-19 05:00:44 UTC
Resetting to defaults for PM consideration.


Note You need to log in before you can comment on or make changes to this bug.