Bug 584957 - 1.1.6: Support selecting more than one component per bug report
1.1.6: Support selecting more than one component per bug report
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.6
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
Lukáš Petrovický
:
Depends On:
Blocks: JIRABZ 584954 694046
  Show dependency treegraph
 
Reported: 2010-04-22 15:19 EDT by David Lawrence
Modified: 2014-10-12 18:46 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-20 00:26:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch with work so far for multiple versions/components support (v1) (56.62 KB, patch)
2010-12-14 16:02 EST, David Lawrence
no flags Details | Diff

  None (edit)
Description David Lawrence 2010-04-22 15:19:11 EDT
JIRA Requirement: 1.1.6

JIRA currently supports the selection of more than one component for new issue. Bugzilla only allows selecting of a single component for a new bug. The component selected
in Bugzilla also decides who the bug is initially assigned to unless the submitter overrides the value. JIRA issues are initially unassigned unless the issue's project is configured to assign the new issues to the project lead. 

We could implement functionality to allow multiple components in Bugzilla but we would need to figure out how to handle the assignee of the new bug as each component
may have a different initial owner. We can mimic unassigned owners by having a Bugzilla account that is not a specific person and have that account as the initial owner (i.e. anaconda-maint@redhat.com, etc.).

Bugzilla also does not have a way to assign a product lead account in order to use that account as the initial owner so that would need to be implemented also if 
we wanted to go that route.

Possible Solution(s): 

 * Implement multiple component functionality in Bugzilla and have Bugzilla select the first owner from the first selected component as the initial owner and add the other owners to the cc list of the new bug.
 * Do above and update the bug UI to allow the user to select which owner of the selected components to pick. Problem is most new users will not know who to pick.
 * Keep the single component method intact and create an additional field that allows user to select extra components (maybe custom field) and the extra components do not have initial owners assigned to them.
 * Add product lead to each product in Bugzilla. When selecting multiple components have Bugzilla choose the product lead instead. Allow the product lead using the product admin page to configure the default behaviour in certain situations.
Comment 1 Max Kanat-Alexander 2010-05-26 17:52:33 EDT
  I'd go with the "create an additional field" method. You could add the Assignee and QA Contact of the additional components to the CC list.
Comment 2 David Lawrence 2010-05-27 17:40:31 EDT
Again we have the problem with having multiple custom fields, one per product due to different values for each, and then having an ever growing boolean charts drop down. And also the two list would need to be kept in sync through changes to  editcomponents.cgi. Unless there is code hacks to keep the custom fields empty and the UI pulls the component list from the core component field and dynamically fills in the extra components drop down. But that still doesn't help the boolean charts issue.
Comment 3 Max Kanat-Alexander 2010-05-27 20:00:05 EDT
Okay. Like I mentioned in the other bug, probably the best solution is allowing multi-value value controllers.
Comment 4 David Lawrence 2010-06-01 17:29:14 EDT
Also commented in the other bug about this as well.
Comment 5 Mike Harvey 2010-10-11 14:56:02 EDT
Assigned to Trevor to verify/QA.  https://bz-web2-test.devel.redhat.com/

You can select a single componet or additional components using the Extra Components custom field. The lists should be the same. The JIRA issues migrated should have these fields populated properly.
Comment 6 Mike Harvey 2010-10-26 15:25:53 EDT
Assigning this to Max to review.  Len and I looked at this feature.  The Extra
Components custom field feature "as coded" tested and works fine...we did not find any bugs.  

I have to say...in reading the original requirements...they are not very clear to me, so I cannot say that this feature meets the requirements.  The solution delivered is clear to me.
Comment 7 Max Kanat-Alexander 2010-10-26 18:24:05 EDT
Hey Mike. When you say the "original requirements", are you actually reading the Requirements Document that Everything Solved produced for Red Hat? Because that's where the requirements would be.
Comment 8 Mike Harvey 2010-10-28 09:16:25 EDT
Hi Max Kanat-Alexander,  I'm referring to :  https://engineering.redhat.com/trac/bugzilla/wiki/JiraMigrationRequirements  line item 1.1.6.  My note was to Max Andersen (JBDS) Dev Tech lead.  He was actually involved in the origination of 1.1.6.
Comment 9 Mike Harvey 2010-11-10 06:31:00 EST
Max Andersen,  Can you look at this feature and comment when you have a chance?

https://bz-web2-test.devel.redhat.com/

If you feel it does not meet the requirement, then please change the Status back to "Assigned" and clearly state the requirement that has not been met.

If all requirements are met, then please change the status to "verified."

Thanks.
Comment 10 David Lawrence 2010-11-30 17:51:50 EST
Just as a status report on this. I am trying to work the code in such a way to allow just selecting multiple components/versions in the standard Bugzilla version fields when viewing the bug in show_bug.cgi or entering a new bug with enter_bug.cgi. 

To accomplish this I am having to backport some changes from the upstream 4.0 version (set_all functionality) and is why it is taking slightly longer than expected. I am doing this to make the UI more intuitive and it is utilizing the work down also by the contractor for the JIRA requirements.

Most of the hard stuff will be done in the background and the user will just need to use the version and component fields as if they are multi select. You can sort of see this working now on bz-web2-test.devel.redhat.com by entering a new bug report, select multiple version/components and then commit. 

I will leave it ON_QA so that Max Anderson can take a look at what is there so far but it is not 100% working yet.

Thanks
Dave
Comment 11 David Lawrence 2010-12-14 16:02:50 EST
Created attachment 468700 [details]
Patch with work so far for multiple versions/components support (v1)

Simon/Noura. Here is a patch from work to date on this bug and the other related bug (multiple component support) that I was almost complete. I have to backport some code from the upstream (4.0) that has a proper Bugzilla::Bug->set_all to allow this work as expected. When this is complete, it should allow for the version and component fields to be multi select fields and then split the values in the backend to the extra custom fields. It is using extension hooks to do most of the work as done by our BZ contractor. Please email me at dklawren@gmail.com for any more info on this if you get stuck or whatever.

Take care
Dave
Comment 16 Lukáš Petrovický 2011-04-21 09:11:01 EDT
I consider this resolved.

Note You need to log in before you can comment on or make changes to this bug.