Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 584969 - rpath complaints building evince RPM
rpath complaints building evince RPM
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 15:49 EDT by Matthew Saltzman
Modified: 2010-12-03 10:34 EST (History)
1 user (show)

See Also:
Fixed In Version: evince-2.28.2-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 10:34:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2010-04-22 15:49:17 EDT
Description of problem:
On attempting to rebuild the evince RPM, I get several complaints about standard rpaths duplicated in library files.

Version-Release number of selected component (if applicable):
evince-2.28.2-1.fc12.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Grab the SRPM
2. rpmbuild --rebuild <...>.srpm
3.
  
Actual results:
rpath errors

Expected results:
no errors

Additional info:
My .rpmmacros file was created by rpmdev-setuptree and contains 
    %__arch_install_post   /usr/lib/rpm/check-rpaths   /usr/lib/rpm/check-buildroot

I solved the problem by adding

    chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_libdir}/nautilus
/extensions-2.0/*.so ${RPM_BUILD_ROOT}%{_libdir}/evince/1/backends/*.so ${RPM_BU
ILD_ROOT}%{_bindir}/*

at the end of the %install section of the spec file.
Comment 1 Marek Kašík 2010-07-23 05:49:10 EDT
Hi Matthew,

I've removed the RPath from evince and also *.a files which triggered additional errors. You can find it in Koji now.

Thank you for this report

Marek
Comment 2 Matthew Saltzman 2010-07-29 08:00:49 EDT
Marek-

Is there a F13 build?  Or is this not an issue with F13?  I've updated to F13, so I can't test the F12 build anymore.  Haven't tried to rebuild the F13 package yet.

Thx.
Comment 3 Marek Kašík 2010-07-29 08:26:55 EDT
Hi Matthew,

I've removed RPath (and also static libraries) from evince in F-13 few months ago. It has been removed in evince-2.30.0-6. There should be 2.30.3-1 in repositories already.

Regards

Marek
Comment 4 Bug Zapper 2010-11-03 12:32:58 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2010-12-03 10:34:13 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.