Bug 584972 - unable to update, old fc10 packages marked required by new fc12 packages
Summary: unable to update, old fc10 packages marked required by new fc12 packages
Keywords:
Status: CLOSED DUPLICATE of bug 574484
Alias: None
Product: Fedora
Classification: Fedora
Component: hulahop
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Simon Schampijer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-22 19:53 UTC by Jeremy Huddleston
Modified: 2010-04-23 06:33 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-23 06:33:29 UTC
Type: ---


Attachments (Terms of Use)

Description Jeremy Huddleston 2010-04-22 19:53:00 UTC
Description of problem:

I can't update fc12.  During yum update, I see:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
python(abi) = 2.5 is needed by (installed) hulahop-1:0.4.6-5.fc10.x86_64
Please report this error in http://yum.baseurl.org/report
1:hulahop-0.4.6-5.fc10.x86_64 has missing requires of python(abi) = ('0', '2.5', None)

For some reason hulahop from fc10 is present and is blocking some python changes.  yum fails to update hulahop:

[jeremy@tifa-linux ~]$ sudo yum update hulahop
[sudo] password for jeremy: 
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Update Process
No Packages marked for Update

And trying to remove it shows it is a dependency of an fc12 package:

[jeremy@tifa-linux ~]$ rpm -e hulahop
error: Failed dependencies:
	hulahop is needed by (installed) sugar-browse-114-1.fc12.noarch

Comment 1 Panu Matilainen 2010-04-23 06:33:29 UTC

*** This bug has been marked as a duplicate of bug 574484 ***


Note You need to log in before you can comment on or make changes to this bug.