Bug 584989 - ValueError: Error parsing "proxy = 'proxy.home:3128'": URL must be http, ftp or https not "proxy.home"
ValueError: Error parsing "proxy = 'proxy.home:3128'": URL must be http, ftp ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
anaconda_trace_hash:b30ed988f0b0a86eb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 16:29 EDT by Brian Lane
Modified: 2010-04-28 20:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-28 20:29:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (292.77 KB, text/plain)
2010-04-22 16:29 EDT, Brian Lane
no flags Details

  None (edit)
Description Brian Lane 2010-04-22 16:29:52 EDT
The following was filed automatically by anaconda:
anaconda 13.21.30 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 97, in __set__
    value, str(e)))
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 508, in populate
    setattr(self, name, value)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 862, in readMainConfig
    yumconf.populate(startupconf._parser, 'main')
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 284, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File "/usr/lib/anaconda/yuminstall.py", line 650, in doConfigSetup
    YumSorter._getConfig(self)
  File "/usr/lib/anaconda/yuminstall.py", line 352, in setup
    self.doConfigSetup(root=self.anaconda.rootPath)
  File "/usr/lib/anaconda/yuminstall.py", line 1145, in doBackendSetup
    self.ayum.setup()
  File "/usr/lib/anaconda/backend.py", line 286, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1258, in nextClicked
    self.anaconda.dispatch.gotoNext()
ValueError: Error parsing "proxy = 'proxy.home:3128'": URL must be http, ftp or https not "proxy.home"
Comment 1 Brian Lane 2010-04-22 16:29:55 EDT
Created attachment 408439 [details]
Attached traceback automatically from anaconda.
Comment 2 Brian Lane 2010-04-22 16:38:25 EDT
I think this is due to passing asknetwork and proxy=http://proxy.home:3128 to the kernel. At the text-mode network dialog it has stripped off the http:// from the URL.
Comment 4 RHEL Product and Program Management 2010-04-22 19:12:41 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Radek Vykydal 2010-04-26 05:03:21 EDT
Brian, isn't this one a dupe of bug #576691?
Comment 6 Brian Lane 2010-04-26 12:17:25 EDT
I don't think so, in that bug it says they left off http, in my case I was passing it to the kernel and am sure it had http://, it loaded stage2 ok, but I suspect that something stripped off the http before it gets to the repo/package chooser dialog. clumens made some fixes to the proxy support in loader recently so that may be what is causing this problem.
Comment 7 Brian Lane 2010-04-28 20:29:21 EDT
Retested this with latest nightly DVD and it no longer throws an exception. Instead in stage2 it forgets the proxy setting entered on the command line, although it does show it correctly in the asknetwork text dialog.

It also won't complete the network install, even after entering the proxy information.

I'm going to close this and try to track down the current behavior I am seeing.

Note You need to log in before you can comment on or make changes to this bug.