Bug 584997 - "yum -y --skip-broken --nogpgcheck upgrade" removes(!?) all packages
Summary: "yum -y --skip-broken --nogpgcheck upgrade" removes(!?) all packages
Status: CLOSED DUPLICATE of bug 585424
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-langpacks (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-22 20:58 UTC by Jim Meyering
Modified: 2016-04-26 21:27 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 19:39:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sole file from /var/lib/yum/history/ (544.00 KB, application/octet-stream)
2010-04-22 21:00 UTC, Jim Meyering
no flags Details
tarball of /var/lib/yum/yumdb contents (1.74 KB, application/x-xz)
2010-04-23 06:29 UTC, Jim Meyering
no flags Details

Description Jim Meyering 2010-04-22 20:58:00 UTC
Description of problem: yum somehow uninstalled all packages


Version-Release number of selected component (if applicable): whatever
version was current in F13 on April 21.

How reproducible: don't know


Steps to Reproduce:
1. yum -y --skip-broken --nogpgcheck upgrade
2. discover that /bin has been removed, along with many other things
3.
  
Actual results:


Expected results:

Additional info:

attacing the single file from /var/lib/yum/history/, ...

Comment 1 Jim Meyering 2010-04-22 20:59:00 UTC
P.S., reported in more detail here:
http://thread.gmane.org/gmane.linux.redhat.fedora.devel/132063

Comment 2 Jim Meyering 2010-04-22 21:00:14 UTC
Created attachment 408444 [details]
sole file from /var/lib/yum/history/

Comment 3 seth vidal 2010-04-22 21:17:02 UTC
Jim,
 Can you also tar up /var/lib/yum/yumdb/ and attach it?

thanks

Comment 4 seth vidal 2010-04-22 21:31:46 UTC
I have a theory I can't prove yet - but I bet this is --skip-broken removing pkgs from being updated and NOT removing their erasure component.

Comment 5 Jim Meyering 2010-04-23 06:29:32 UTC
Created attachment 408505 [details]
tarball of /var/lib/yum/yumdb contents

Comment 6 Tim Lauridsen 2010-04-23 11:33:15 UTC
(In reply to comment #4)
> I have a theory I can't prove yet - but I bet this is --skip-broken removing
> pkgs from being updated and NOT removing their erasure component.    

This is why _checkMissingObsoleted & _checkUpdatedLeftovers was added to handle leftover erasure components, so this should not happen in F13.

Comment 7 Mamoru TASAKA 2010-04-23 12:22:23 UTC
Same as bug 561928?

Comment 8 Tim Lauridsen 2010-04-23 13:15:09 UTC
(In reply to comment #7)
> Same as bug 561928?    

No, it is another issues, fixed here

http://yum.baseurl.org/gitweb?p=yum.git;a=commit;h=f8c15289427c24130a7cdf5bf2f9eb524fc3fa19

Comment 9 seth vidal 2010-04-26 19:39:05 UTC
over to langpacks.

*** This bug has been marked as a duplicate of bug 585424 ***


Note You need to log in before you can comment on or make changes to this bug.