Bug 58500 - "Canned" boot configuration not too useful
"Canned" boot configuration not too useful
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Beth Uptagrafft
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-18 00:28 EST by Michal Jaegermann
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-30 13:46:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-01-18 00:28:18 EST
Description of Problem:


After applying patches to kernel sources to make them bootable and
using kernel-2.4.9-alpha-BOOT.config for a .config file to create a
"rescue" kernel it turns out that its usefulness is rather limited.
There is no way to mount CD if a drive is ATAPI as ide_cd is a module
which is missing (and which can be retrieved with some effort from
'ramdisk.img' which is, obviously, on CD).  Also bringing up
network is not that simple because 'service network start' assumes
that NETLINK support is present but in a configuration used this is
not true.  Floppy still works.  Probably a grave oversight.

Seriously, there are practically no other CD devices on Alphas as SCSI
and ATAPI as firmware limits choices so compiling in ide_cd support
would make it much more usable.  Making a boot kernel "network ready"
would be nice as well.  There is still enough space on a floppy for
such big splash.
Comment 1 Phil Copeland 2002-04-22 00:44:35 EDT
Humm

Well if you have the first ISO of the CD install you can actually pass the boot
command argument 'rescue', and the CD will bootup and come to rest at a shell
prompt from which you should be able to access the HD and make all the repairs
needed

This also works for the generic/ramdisk floppies.

The floppies are quite packed. I fear that 1440K just isn't enough these days.

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.