Bug 585047 - IPv6 DHCP causes system boot to hang if IPv6 DHCP server is unavailable
IPv6 DHCP causes system boot to hang if IPv6 DHCP server is unavailable
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
Miroslav Vadkerti
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 21:18 EDT by Norman
Modified: 2014-09-08 07:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: initscripts-9.03.6-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:40:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suggested patch (1.21 KB, patch)
2010-04-23 08:50 EDT, Jiri Popelka
no flags Details | Diff

  None (edit)
Description Norman 2010-04-22 21:18:58 EDT
Description of problem:
If system is configured to use DHCP over IPv6, but DHCP server is unavailable, system hangs indefinitely.

Version-Release number of selected component (if applicable):
RHEL 6.0 beta 1


How reproducible:
100%


Steps to Reproduce:
1. DHCPV6C=yes in /etc/sysconfig/network-scripts/ifcfg-eth0
2. ensure no DHCP IPv6 server is running on network
3. reboot client
  
Actual results:
RHEL 6.0 beta 1 system hangs while trying to bring up NIC

Expected results:
'dhclient -6' should return an error and/or continue in the background

Additional info:
Comment 2 RHEL Product and Program Management 2010-04-22 22:54:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Jiri Popelka 2010-04-23 08:49:36 EDT
Thank you for the report Norman.

I think the problem is not in dhclient.
I'm going to switch the component to initscripts and here is the explanation:

If the ISC client for DHCPv4 receives no response to its broadcast message
in the INIT state, it continues retransmitting DHCPDISCOVER messages
for some configurable period of time and than it either
exits (when running dhclient with -1 parameter)
or becomes a daemon (when running without -1 parameter).

If the ISC client for DHCPv6 receives no response to its Solicit message, it
continues retransmitting Solicit messages for some configurable period of
time and than it either exits (when running dhclient with -1 parameter) or
continues running in foreground (when running without -1 parameter).

When the client for DHCPv6 is started (without -1) during system startup and it
receives no response to its Solicit messages it doesn't "give up" and
holds up the system indefinitely.

I can ask upstream (ISC) if this is a bug or it is intentional,
but I think this is not important for this bug report.

What I think is important is that ifup-eth starts dhclient for DHCPv4 by default (when PERSISTENT_DHCLIENT=yes is not used) with -1 parameter.

So I suggest to start dhclient for DHCPv6 also with -1 parameter
so it will behave like the dhclient for DHCPv4.

There's also -nw parameter. man dhclient says:
"-nw    Become a daemon process immediately (nowait) rather than waiting until an IP address has been acquired."
This also solves the problem,
but I think the "-1" parameter is what we need.
Comment 4 Jiri Popelka 2010-04-23 08:50:23 EDT
Created attachment 408599 [details]
suggested patch
Comment 5 Bill Nottingham 2010-04-23 14:33:13 EDT
Merged without the echos.
Comment 8 Miroslav Vadkerti 2010-09-17 15:33:01 EDT
VERIFIED as fixed in initscripts-9.03.17-1.el6. 

service network restart now works fine and does not hang

NEW package initscripts-9.03.17-1.el6:
:: [   PASS   ] :: Running '(service network restart; echo PASS) &> /tmp/tmp.8mhQCoT3iP &'
:: [   PASS   ] :: Running 'sleep 5m'
:: [   PASS   ] :: File '/tmp/tmp.8mhQCoT3iP' should contain 'PASS'


OLD package initscripts-9.03.5-1.el6:
:: [   PASS   ] :: Running '(service network restart; echo PASS) &> /tmp/tmp.AVpvaDDujA &'
:: [   PASS   ] :: Running 'sleep 5m'
:: [   FAIL   ] :: File '/tmp/tmp.AVpvaDDujA' should contain 'PASS'
Comment 9 releng-rhel@redhat.com 2010-11-10 15:40:07 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.