Bug 585048 - No longer work with new Epiphany
Summary: No longer work with new Epiphany
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: epiphany-extensions   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 591465 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 01:21 UTC by Bruce Cowan
Modified: 2010-05-14 09:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-14 09:58:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to adapt epiphany-extension to new layout (1.33 KB, patch)
2010-05-07 16:58 UTC, Michael S.
no flags Details | Diff

Description Bruce Cowan 2010-04-23 01:21:50 UTC
Description of problem:

Epiphany now looks in /usr/lib/epiphany/2.29/ for extensions, but they are installed in /2.30/. As far as I can tell, this is because they should be installed according to "ephy_api_version", not "ephy_major" any more.

Version-Release number of selected component (if applicable):
epiphany 2.30.2-1.fc13
epiphany-extensions 2.30.0-1.fc13

Comment 1 Michael S. 2010-05-07 16:01:38 UTC
Indeed, adding a link solved the issue for me.

Comment 2 Michael S. 2010-05-07 16:57:30 UTC
A rebuild fixed it for me, here is a patch.

Comment 3 Michael S. 2010-05-07 16:58:24 UTC
Created attachment 412402 [details]
Patch to adapt epiphany-extension to new layout

Comment 4 Bastien Nocera 2010-05-14 09:58:57 UTC
I've fixed this in the 2.30.1 build of the extensions.

Comment 5 Bastien Nocera 2010-05-14 09:59:22 UTC
*** Bug 591465 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.