Bug 585071 - Anaconda can not use pci.ids in dud image.
Summary: Anaconda can not use pci.ids in dud image.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda
Version: 4.7
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 04:12 UTC by Hajime Taira
Modified: 2010-04-23 13:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-23 13:25:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Hajime Taira 2010-04-23 04:12:22 UTC
Description of problem:
I have a few issue about processing pci.ids in dud for anaconda.

I backported bnx2x driver 1.50.16 to RHEL4U7, I included pci.ids to dud image.
When I tried installation with it. Anaconda display following device at chooseNetworkInterface() in anaconda.

"eth0 - Broadcom Corporation : Unknown device 1650"
"eth1 - Broadcom Corporation : Unknown device 1650"
"eth2 - Broadcom Corporation : Unknown device 1650"
"eth3 - Broadcom Corporation : Unknown device 1650"

Because anaconda ignore pci.ids in dud image.
Was this expected processing? or not assume it?

It should be display following.

"eth0 - Broadcom Corporation : NC532i Dual Port 10GbE Multifunction BL-C Adapter"
"eth1 - Broadcom Corporation : NC532i Dual Port 10GbE Multifunction BL-C Adapter"
"eth2 - Broadcom Corporation : NC532m Dual Port 10GbE Multifunction BL-C Adapter"
"eth3 - Broadcom Corporation : NC532m Dual Port 10GbE Multifunction BL-C Adapter"

I looked sources at anaconda, and kuzdu, pciutils.
source: pci.c from kudzu
    if (!access("/usr/share/hwdata/pci.ids", R_OK))
         pacc->id_file_name = "/usr/share/hwdata/pci.ids";
    else if (!access("/etc/pci.ids", R_OK))
         pacc->id_file_name = "/etc/pci.ids";
    else if (!access("/modules/pci.ids", R_OK))
         pacc->id_file_name = "/modules/pci.ids";
    else if (!access("./pci.ids", R_OK))
         pacc->id_file_name = "./pci.ids";
    else if (pcifiledir) {
              snprintf(pcifile,128,"%s/pci.ids",pcifiledir);
                   if (!access(pcifile, R_OK))
                       pacc->id_file_name = pcifile;
                   }

Finally, I changed pci.ids in images/pxeboot/initrd.img.
I think that there should be some method to let anaconda display it neatly.

Version-Release number of selected component (if applicable):


How reproducible:
Install RHEL4U7 with DUD image.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Can not use pci.ids in dud image.

Expected results:
Use pci.ids in dud image.

Additional info:

Comment 1 Chris Lumens 2010-04-23 13:25:17 UTC
We are not doing RHEL4 updates for anaconda any longer unless some complete disaster is discovered, so this is unlikely to get fixed.  Sorry.  Please let us know whether you're seeing this problem in RHEL5 or RHEL6, though.


Note You need to log in before you can comment on or make changes to this bug.