Bug 585072 - kerneloops after wireless connection established
kerneloops after wireless connection established
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 587727
  Show dependency treegraph
 
Reported: 2010-04-23 00:38 EDT by Danny Stieben
Modified: 2010-05-25 13:29 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-2.6.33.3-72.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 587727 (view as bug list)
Environment:
Last Closed: 2010-05-25 13:29:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Danny Stieben 2010-04-23 00:38:38 EDT
Description of problem: Right after I tried to connect to my wireless network (successfully), I came with a kerneloops error. (I reported this once on Fedora 12 too, but at first I thought it had something to do with VirtualBox).


How reproducible: Simply connected to my wireless network, and abrt said there was a kerneloops.


Additional info: Info direct from abrt:

------------[ cut here ]------------
WARNING: at kernel/softirq.c:143 _local_bh_enable_ip+0x3e/0xab()
Hardware name: Aspire 6530      
Modules linked in: aes_i586 aes_generic fuse sunrpc cpufreq_ondemand powernow_k8 ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 uinput snd_hda_codec_atihdmi microcode snd_hda_codec_realtek arc4 ecb uvcvideo videodev v4l1_compat snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device k10temp hwmon joydev snd_pcm serio_raw ath9k ath9k_common i2c_piix4 mac80211 ath9k_hw ath cfg80211 snd_timer rfkill snd soundcore atl1e snd_page_alloc wmi pata_acpi ata_generic usb_storage pata_atiixp video output radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
Pid: 1144, comm: wpa_supplicant Not tainted 2.6.33.2-57.fc13.i686 #1
Call Trace:
[<c043b55a>] warn_slowpath_common+0x6a/0x81
[<c0441149>] ? _local_bh_enable_ip+0x3e/0xab
[<f901696a>] ? ath_tx_node_cleanup+0xee/0x106 [ath9k]
[<c043b583>] warn_slowpath_null+0x12/0x15
[<c0441149>] _local_bh_enable_ip+0x3e/0xab
[<c04411c3>] local_bh_enable_ip+0xd/0xf
[<c07b41e8>] _raw_spin_unlock_bh+0x2a/0x2d
[<f901696a>] ath_tx_node_cleanup+0xee/0x106 [ath9k]
[<f9012339>] ath9k_sta_notify+0x79/0x7d [ath9k]
[<f8fa26a5>] __sta_info_unlink+0x11b/0x171 [mac80211]
[<f90122c0>] ? ath9k_sta_notify+0x0/0x7d [ath9k]
[<f8fa2723>] sta_info_unlink+0x28/0x36 [mac80211]
[<f8fa78f0>] ieee80211_set_disassoc+0x18a/0x19f [mac80211]
[<f8fa7db9>] ieee80211_mgd_deauth+0x42/0x104 [mac80211]
[<c04624c1>] ? mark_held_locks+0x43/0x5b
[<f8fad1d1>] ieee80211_deauth+0x19/0x1b [mac80211]
[<f8ecd98c>] __cfg80211_mlme_deauth+0xf0/0xf9 [cfg80211]
[<f8ecfc99>] __cfg80211_disconnect+0xee/0x154 [cfg80211]
[<f8ed27f4>] cfg80211_wext_siwmlme+0x64/0x86 [cfg80211]
[<c079992a>] ioctl_standard_call+0x1f5/0x29e
[<f8ed2790>] ? cfg80211_wext_siwmlme+0x0/0x86 [cfg80211]
[<c072516b>] ? dev_name_hash+0x1b/0x4d
[<c0799aca>] wext_handle_ioctl+0xf7/0x181
[<f8ed2790>] ? cfg80211_wext_siwmlme+0x0/0x86 [cfg80211]
[<c0729a26>] dev_ioctl+0x546/0x577
[<c0718f32>] sock_ioctl+0x1e9/0x1f5
[<c04eb565>] vfs_ioctl+0x2c/0x96
[<c0718d49>] ? sock_ioctl+0x0/0x1f5
[<c04ebb18>] do_vfs_ioctl+0x49b/0x4d9
[<c058ea59>] ? selinux_file_ioctl+0x43/0x46
[<c04ebb9c>] sys_ioctl+0x46/0x66
[<c07b4434>] syscall_call+0x7/0xb

Running fully updated Fedora 13 with all repos enabled, i686.
Comment 1 Danny Stieben 2010-04-24 21:43:32 EDT
Looking on the kerneloops.org site, there seem to be a lot of ath_tx_node_cleanup errors, just like the problem that I have.
Comment 2 Henry Kroll 2010-04-26 15:54:38 EDT
This happens to me sometimes when connecting under load. Sometimes with firefox running. VirtualBox would be a good candidate. Basically anything that uses CPU. 

I get a similar kernel oops when waking up from suspend
https://bugzilla.kernel.org/show_bug.cgi?id=15839

In the latter case, Xorg is hogging CPU cycles. The common thread seems to be CPU usage.
Comment 3 John W. Linville 2010-04-27 15:16:17 EDT
I suspect this relates to an earlier patch which fixed a lockdep warning.  I have reverted that patch in the test kernels here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2141465

Could you give those a try and see if the oops you are seeing disappears?
Comment 4 Henry Kroll 2010-04-27 16:32:44 EDT
The kernel oops stopped happening yesterday after reporting it and has not returned.

 tail yum.log

Apr 25 15:00:08 Updated: nautilus-2.30.0-3.fc13.x86_64
Apr 25 15:00:09 Updated: nautilus-extensions-2.30.0-3.fc13.x86_64
Apr 25 15:00:11 Updated: libchamplain-0.4.5-1.fc13.x86_64
Apr 25 15:00:12 Updated: libchamplain-gtk-0.4.5-1.fc13.x86_64
Apr 25 15:00:13 Updated: schroedinger-1.0.9-2.fc13.x86_64
Apr 25 15:00:26 Updated: gcalctool-5.30.0-2.fc13.x86_64
Apr 25 15:00:28 Updated: taglib-1.6.3-1.fc13.x86_64
Apr 25 15:00:29 Updated: prelink-0.4.3-3.fc13.x86_64
Apr 25 15:00:31 Updated: telepathy-butterfly-0.5.9-1.fc13.noarch
Apr 27 01:11:50 Installed: gpm-libs-1.20.6-9.fc13.x86_64
Apr 27 01:11:52 Installed: nss_compat_ossl-0.9.6-1.fc13.x86_64
Apr 27 01:11:53 Installed: 1:links-2.2-12.fc13.x86_64
Apr 27 08:36:26 Installed: lshw-B.02.14-3.fc12.x86_64
Comment 5 Danny Stieben 2010-04-27 18:55:28 EDT
Went ahead and installed kernel-2.6.33.2-68.bz585072.fc13.i686.rpm and kernel-headers-2.6.33.2-68.bz585072.fc13.i686.rpm...so far there are no more errors/oopses, but I only have it installed for about 20 minutes, so I'll need to use it a bit longer before I can say for sure.
Comment 6 Danny Stieben 2010-04-27 19:49:47 EDT
OK, suggestion that I tried out seems to work...no more kernel oops problems.
Comment 7 John W. Linville 2010-04-28 09:45:50 EDT
Alright, that at least points at the problem -- unfortunately, that patch was also fixing a problem.  Hopefully we can find a solution for both issues...
Comment 8 John W. Linville 2010-04-28 10:41:45 EDT
Scratch that last comment -- it looks like that patch was mistakenly backported to the stable kernel series for 2.6.33...
Comment 9 Danny Stieben 2010-04-28 12:05:52 EDT
So that means that the patch is no longer needed? So removing it would still have both problems solved?
Comment 10 John W. Linville 2010-04-28 13:29:12 EDT
Yes -- that is to say that applying my patch to revert the other should resolve the issue you reported here while avoiding the problem that the problematic patch was intended to solve.

http://koji.fedoraproject.org/koji/buildinfo?buildID=169229
Comment 11 Fedora Update System 2010-04-28 14:16:45 EDT
kernel-2.6.33.3-72.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kernel-2.6.33.3-72.fc13

Note You need to log in before you can comment on or make changes to this bug.