Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585103 - DeviceError: ('cannot replace active format', 'sda1')
DeviceError: ('cannot replace active format', 'sda1')
Status: CLOSED DUPLICATE of bug 563526
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
anaconda_trace_hash:8daf23e4418e9ca2a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 02:44 EDT by william.hoffmann
Modified: 2010-04-23 09:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 09:33:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (143.14 KB, text/plain)
2010-04-23 02:44 EDT, william.hoffmann
no flags Details

  None (edit)
Description william.hoffmann 2010-04-23 02:44:39 EDT
The following was filed automatically by anaconda:
anaconda 13.21.20.5 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 697, in _setFormat
    raise DeviceError("cannot replace active format", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 1171, in _setFormat
    StorageDevice._setFormat(self, format)
  File "/usr/lib/anaconda/storage/devices.py", line 705, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/anaconda/storage/deviceaction.py", line 307, in __init__
    self.device.format = None
  File "/usr/lib/anaconda/storage/__init__.py", line 782, in destroyDevice
    self.devicetree.registerAction(ActionDestroyFormat(device))
  File "/usr/lib/anaconda/storage/partitioning.py", line 370, in clearPartitions
    storage.destroyDevice(part)
  File "/usr/lib/anaconda/storage/partitioning.py", line 184, in doAutoPartition
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1396, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1309, in nextClicked
    self.setScreen ()
DeviceError: ('cannot replace active format', 'sda1')
Comment 1 william.hoffmann 2010-04-23 02:44:43 EDT
Created attachment 408509 [details]
Attached traceback automatically from anaconda.
Comment 3 william.hoffmann 2010-04-23 04:02:17 EDT
I wanted to install RHEL6 beta, on a machine with an already partitioned hardrive. I've choosen to create a new partitioning layout, with encrypted vg then I got the anaconda message. After deletion of the partition table (dd if=/dev/zero of=/dev/sda bs=512 count=2) the installation went well.
Comment 4 RHEL Product and Program Management 2010-04-23 04:03:21 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Chris Lumens 2010-04-23 09:33:35 EDT

*** This bug has been marked as a duplicate of bug 563526 ***

Note You need to log in before you can comment on or make changes to this bug.