Bug 585115 - Internal PDF table borders not the same weight as external borders.
Summary: Internal PDF table borders not the same weight as external borders.
Status: CLOSED ERRATA
Alias: None
Product: Publican
Classification: Community
Component: publican   
(Show other bugs)
Version: 1.6
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Fearn ๐Ÿž
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 07:12 UTC by Jared MORGAN
Modified: 2015-08-10 01:21 UTC (History)
7 users (show)

Fixed In Version: publican-1.6.3-0.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-17 18:57:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the PDF table with feint internal borders (67.56 KB, image/png)
2010-04-23 07:12 UTC, Jared MORGAN
no flags Details
HTML Single output of the table with no internal borders (42.33 KB, image/png)
2010-04-23 07:13 UTC, Jared MORGAN
no flags Details
The XML code for the table that appears in the screenshots. (3.99 KB, text/xml)
2010-04-23 07:15 UTC, Jared MORGAN
no flags Details

Description Jared MORGAN 2010-04-23 07:12:21 UTC
Created attachment 408514 [details]
Screenshot of the PDF table with feint internal borders

Description of problem:

In PDF docs, tables do not have internal row and column separators that are the same line weight as the external borders.

In HTML, the internal row and column separators are missing entirely.


Version-Release number of selected component (if applicable):

Publican version 1.6.2


How reproducible:

Consistently, across the JBoss and Common brands.  Other brands not tested.

Steps to Reproduce:
1. Create a table using the attached XML syntax (to make it easy), and publish to PDF and HTML.
2. Analyze the output.
  
Actual results:

PDF tables have a different line weight to the external border (the "frame" attribute).

HTML tables have a frame, but no internal borders.

Expected results:

The PDF tables have the same line weight for all borders.

The HTML tables have internal borders that use the same line weight as the frames.

Additional info:

Spoke with rudi, and he seemed to think this problem was raised in another ticket for one of the brands. However it may not have been implemented in the other brands.

Comment 1 Jared MORGAN 2010-04-23 07:13:06 UTC
Created attachment 408515 [details]
HTML Single output of the table with no internal borders

Comment 2 Jared MORGAN 2010-04-23 07:15:10 UTC
Created attachment 408518 [details]
The XML code for the table that appears in the screenshots.

Comment 4 Jeff Fearn ๐Ÿž 2010-04-27 05:09:05 UTC
The difference in the PDF borders is a matter of taste, and they look fine to me.

The HTML renders properly for me, i.e. you can see the cell borders, using both publican-jboss and the default brand.

Comment 5 Jared MORGAN 2010-04-27 05:55:50 UTC
(In reply to comment #4)
> The difference in the PDF borders is a matter of taste, and they look fine to
> me.
> 
> The HTML renders properly for me, i.e. you can see the cell borders, using both
> publican-jboss and the default brand.   

Hmm, it seems that Chromium might be to blame here Jeff. I've opened up the same file in Firefox, and the borders are there.  They are also all the same line weight.  

I can confirm that the HTML output seems to be "fixed" as long as you don't use Google Chrome for Linux.  Any ideas as to why Chromium might be interpreting the CSS differently?  If so, I can raise a bug directly with chrome to see if I can get the issue fixed with them.

From a consistency perspective, wouldn't it make sense to have tables in PDF and HTML outputs rendering largely the same?

The lighter table internal borders vary throughout the table in the PDF, and the bottom table border seems to be an inconsistent line weight/colour compared to the other outside edges?

Comment 6 Ruediger Landmann 2010-04-27 06:18:54 UTC
(collision) The output in both formats seems to vary considerably depending on the web browser and PDF viewer in question.

HTML -- internal borders are visible in Firefox and Dillo, but are missing in
Chromium, Konqueror, and Internet Explorer 6.

PDF -- I can't see a difference in weight between internal and external borders
in Okular, XPDF, or Adobe Reader unless I zoom in greater than about 300%;
while in Evince I see the same, large difference in weights as in the
screenshot that Jared attached.

Comment 7 Jeff Fearn ๐Ÿž 2010-04-27 06:23:30 UTC
Added a tweak to the CSS for webkit browsers, upped PDF cell border width to
match table border.

Comment 8 Dana Mison 2010-04-27 06:42:40 UTC
Just confirming that the reported behaviour of no internal borders also manifests on IE8 on Win7 and Safari 4.0.5 on OSX 10.6.3

The internal borders are visible in Firefox 3.5.8 on OSX 

My 2 cents: I'd prefer the internal borders be very slightly fainter than the external ones.

Comment 9 Ruediger Landmann 2010-05-06 05:15:04 UTC
internal borders not visible in Konqueror or Chromium in table built with version 1.6.3.t122

Comment 10 Ruediger Landmann 2010-05-06 05:49:38 UTC
Internal borders visible in Konqueror and Chromium in table built with version 1.6.3.t150

Internal and external borders appear of similar weight in Evince.

Comment 11 Fedora Update System 2010-05-13 22:21:07 UTC
publican-1.6.3-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.6.3-0.fc13

Comment 12 Fedora Update System 2010-05-13 22:22:22 UTC
publican-1.6.3-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.6.3-0.fc12

Comment 13 Fedora Update System 2010-05-15 20:36:47 UTC
publican-1.6.3-0.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update publican'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/publican-1.6.3-0.fc12

Comment 14 Fedora Update System 2010-05-15 20:45:59 UTC
publican-1.6.3-0.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update publican'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/publican-1.6.3-0.fc13

Comment 15 Fedora Update System 2010-05-17 18:56:04 UTC
publican-1.6.3-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-05-17 18:59:55 UTC
publican-1.6.3-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.