Bug 58512 - ncftpget -DD fails to delete remote files
Summary: ncftpget -DD fails to delete remote files
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncftp   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-18 14:48 UTC by criege
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 12:39:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description criege 2002-01-18 14:48:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011013

Description of problem:
calling ncftpget -DD fails to delete the remote file. according to the man page,
-DD should cause the remote file to get deleted after transfer; this does not
happen. tried this with several different remote sites running different ftpd
implementations; access rights to the file are OK.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. $ ncftpget -DD -d -u <user> -p <pass> <site> . test.txt
2. 
3. 
	

Actual Results:  file was retrieved from remote site. file is still at remote
site, didn't get removed

Expected Results:  file shows up locally, is removed at remote site

Additional info:

can reproduce on RH 7.1, too (ncftp 3.0.2)

Comment 1 Karsten Hopp 2003-11-05 12:39:44 UTC
works for me with the current version. Are you sure the permissions
were right ?  Connect with a regular ftp client and try to delete
these files.
Does that work ?


Note You need to log in before you can comment on or make changes to this bug.