Bug 58513 - Updated neat crashes on start (w/ simple solution)
Updated neat crashes on start (w/ simple solution)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-18 09:53 EST by fred-m
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-18 09:53:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fred-m 2002-01-18 09:53:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; T312461)

Description of problem:
The updated neat in redhat-config-network-0.9.10-2.noarch.rpm
crashes on start, with the following message:

Traceback (innermost last):
  File "/usr/sbin/neat", line 96, in ?
    from netconfpkg.gui import *
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/__init__.py", 
line 30, in ?
    exec cmd
  File "<string>", line 1, in ?
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/exception.py", 
line 22, in ?
    import rpm
ImportError: No module named rpm

Fortunately, the cause is simple:
redhat-config-network-0.9.10-2.noarch.rpm is missing a dependency for
rpm-python.

To solve the problem, install the rpm-python package.


Version-Release number of selected component (if applicable):
redhat-config-network-0.9.10-2.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install the updated redhat-config-network without installing rpm-python
2. Run neat

	

Actual Results:  Crashes with message above.

Expected Results:  Program runs, shows GUI window.

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-01-18 10:23:24 EST
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.