Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585140 - totem: XV viewport issues
totem: XV viewport issues
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 04:48 EDT by Hans de Goede
Modified: 2010-04-23 05:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 05:24:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2010-04-23 04:48:33 EDT
Hi,

See bug 582586 for system details and xorg logs from the system in question.

When I start an xvideo app (tried with totem, both embedded in a browser window and standalone). I don't get any video.

I can fix the not getting video by moving a window over the video window. So it seems that the initial state of which part of the XV overlay is not obscured is not correct.

Also when I have a window partially overlapping the XV overlay, and move it away, the part of the video which was overlapped stays black. So it seems that the tracking of which part of the XV overlay is obscured and which one is not, is not working correctly in general.

I also tried with mplayer and there things do work properly, so I believe this is a totem / gstreamer problem.

Note this is a relatively slow machine, so maybe this is some timing issue ?

Regards,

Hans
Comment 1 Bastien Nocera 2010-04-23 05:24:25 EDT
It's a display bug in Totem, fixed in master, and will be released along with the new gstreamer core.

The problem was that the widget was double-buffered when playing video, which it didn't like.

See https://bugzilla.gnome.org/show_bug.cgi?id=614177 for work-arounds

Note You need to log in before you can comment on or make changes to this bug.