Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585153 - RFE: Add XML-RPC-way to access uploaded files
RFE: Add XML-RPC-way to access uploaded files
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.8
All Linux
low Severity medium (vote)
: 0.8.2
: ---
Assigned To: Dan Callaghan
:
: 786127 (view as bug list)
Depends On:
Blocks: 545868
  Show dependency treegraph
 
Reported: 2010-04-23 05:33 EDT by Marian Csontos
Modified: 2012-04-26 03:16 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 03:16:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bkr job-logs (1.82 KB, text/plain)
2012-02-08 05:25 EST, Jiri Kastner
no flags Details

  None (edit)
Description Marian Csontos 2010-04-23 05:33:01 EDT
Description of problem:

There is no way for client to list and get files attached to {recipe,task,result}

This would enable bkr client extension:
  bkr file-list T:1234
  bkr file-get TR:12345 /TESTOUT.log


Version-Release number of selected component (if applicable):

0.5.25
Comment 1 Marian Csontos 2011-03-14 06:09:21 EDT
At least an URL to directory where the files are stored could be exposed in taskactions.to_xml and in taskactions.task_info.

This location changes during lifetime (temporary storage and final destiny) as well as it was reorganized few times in the past.

It is not easy to get to the files: one needs to have a knowledge of server settings (e.g. how are the jobs grouped) which should not be required.
Comment 2 Karel Srot 2011-05-09 02:37:14 EDT
+1 for this feature
Comment 3 Dan Callaghan 2012-01-31 22:43:24 EST
*** Bug 786127 has been marked as a duplicate of this bug. ***
Comment 4 Martin Cermak 2012-02-08 05:19:32 EST
+1 to solving this
Comment 5 Jiri Kastner 2012-02-08 05:25:53 EST
Created attachment 560214 [details]
bkr job-logs

result of my attempt get some logs listed
Comment 6 Martin Cermak 2012-02-08 09:10:23 EST
Good job, Jiri! Thanks for posting this! I temporarily resolved my issues using your script. And I hope your post will also speed up resolving this bz :)
Comment 7 Dan Callaghan 2012-02-20 01:06:57 EST
Patch is up for review on Gerrit:

http://gerrit.beaker-project.org/925

Note You need to log in before you can comment on or make changes to this bug.