Bug 585155 - request for gpm and mc in Fedora installation&rescue images
request for gpm and mc in Fedora installation&rescue images
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 05:36 EDT by Frantisek Hanzlik
Modified: 2013-01-10 00:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 16:07:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Hanzlik 2010-04-23 05:36:26 EDT
Installation (or rather rescue) environment should IMO contain gpm and mc programs, which may be very usefull in rescue tasks:

- gpm's clipboards are very usefull eg. for various operations with UUID (which are used in several last Fedora distros). Using clipboard for these (and other long/bad rememberable) strings is much simpler than some hacks with shell redirections or temporary files.

- mc is very intuitive and illustrative file manager useful for cases in serious filesystem damage (well, I come into them only on other innominate OSs - but Fedora netinst CD I have along already, in contrast with specialized recovery CDs :). In case other file-intensive tasks mc can help too.

Thus, when their inclusion not block other issues, I advocate for adding them to install images.

Thanks, Franta Hanzlik
Comment 1 Chris Lumens 2010-04-23 16:07:15 EDT
anaconda's rescue mode is not intended to provide every possible program that every person may ever need.  At that point, it's just gotten so large as to be its own complete operating system and then you might as well use the livecd or something similar to repair your system.
Comment 2 Frantisek Hanzlik 2010-05-01 23:16:53 EDT
OK, I agree that mc isn't too important and doesn't need to be there. But You should still consider including gpm:
- anaconda rescue mode has text UI, thus clipboard feature provided by gpm may be very usefull
- gpm binary is only about 100 kB in size and depends only on glibc, thus there isn't big growth is size and complexity.

Note You need to log in before you can comment on or make changes to this bug.