Bug 585156 - SELinux is preventing /usr/sbin/cupsd "execute" access on rastertosamsungspl.
SELinux is preventing /usr/sbin/cupsd "execute" access on rastertosamsun...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:a71ff1b7bce...
:
: 588105 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 05:41 EDT by Manoj Kumar Suyal
Modified: 2010-11-30 10:15 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 07:12:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manoj Kumar Suyal 2010-04-23 05:41:29 EDT
Summary:

SELinux is preventing /usr/sbin/cupsd "execute" access on rastertosamsungspl.

Detailed Description:

SELinux denied access requested by cupsd. It is not expected that this access is
required by cupsd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                rastertosamsungspl [ file ]
Source                        cups-deviced
Source Path                   /usr/lib/cups/daemon/cups-deviced
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           cups-1.4.2-28.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-108.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux CEFI1 2.6.32.11-99.fc12.i686 #1 SMP Mon Apr
                              5 16:32:08 EDT 2010 i686 i686
Alert Count                   11
First Seen                    Wed 21 Apr 2010 03:27:06 PM IST
Last Seen                     Wed 21 Apr 2010 04:32:28 PM IST
Local ID                      c696a492-2946-4639-99c1-69344bb100f3
Line Numbers                  

Raw Audit Messages            

node=CEFI1 type=AVC msg=audit(1271847748.822:27396): avc:  denied  { execute } for  pid=12931 comm="cupsd" name="rastertosamsungspl" dev=dm-0 ino=10092 scontext=unconfined_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=CEFI1 type=SYSCALL msg=audit(1271847748.822:27396): arch=40000003 syscall=11 success=no exit=-13 a0=bf9437b6 a1=13d8c08 a2=bf9420bc a3=bf9437b6 items=0 ppid=11533 pid=12931 auid=500 uid=4 gid=7 euid=4 suid=4 fsuid=4 egid=7 sgid=7 fsgid=7 tty=(none) ses=1 comm="cupsd" exe="/usr/sbin/cupsd" subj=unconfined_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,cups-deviced,cupsd_t,user_home_t,file,execute
audit2allow suggests:

#============= cupsd_t ==============
allow cupsd_t user_home_t:file execute;
Comment 1 Miroslav Grepl 2010-04-23 07:12:46 EDT
Where is 'rastertosamsungspl' located? 

If under /usr/lib/cups/filter, then 'rastertosamsungspl' is mislabeled and run

# restorecon -R -v /usr/lib/cups/filter

Please reopen bug if I am wrong.
Comment 2 Miroslav Grepl 2010-05-03 05:52:16 EDT
*** Bug 588105 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.