Bug 585170 - livecd-creator ignores device directive
livecd-creator ignores device directive
Status: CLOSED DUPLICATE of bug 588622
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: David Huff
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 06:37 EDT by Alan Pevec
Modified: 2010-06-20 17:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 584185
Environment:
Last Closed: 2010-06-20 17:53:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to generate dracut.conf instead of /etc/sysconfig/mkinitrd (2.73 KB, patch)
2010-04-23 06:39 EDT, Alan Pevec
no flags Details | Diff

  None (edit)
Description Alan Pevec 2010-04-23 06:37:10 EDT
+++ This bug was initially created as a clone of Bug #584185 +++

Description of problem:
device kickstart directive is ignored because livecd-creator generates /etc/sysconfig/mkinitrd

Version-Release number of selected component (if applicable):
livecd-tools-031-1.6.el6

--- Additional comment from apevec@redhat.com on 2010-04-20 18:16:47 EDT ---

Created an attachment (id=407936)
patch to generate dracut.conf instead of sysconfig/
Comment 1 Alan Pevec 2010-04-23 06:39:58 EDT
Created attachment 408568 [details]
patch to generate dracut.conf instead of /etc/sysconfig/mkinitrd
Comment 2 Harald Hoyer 2010-04-23 07:21:41 EDT
"add_drivers+=" does not work!
Comment 3 Alan Pevec 2010-04-23 07:28:45 EDT
(In reply to comment #2)
> "add_drivers+=" does not work!    

it does, dracut.conf is simply sourced as a shell script
Comment 4 Harald Hoyer 2010-04-23 07:29:12 EDT
+        f.write('add_drivers+="squashfs ext4 ext3 ext2 vfat msdos "\n')
+        f.write('add_drivers+="sr_mod sd_mod ide-cd cdrom "\n')
+                f.write('add_drivers+="ehci_hcd uhci_hcd ohci_hcd "\n')
+                f.write('add_drivers+="usb_storage usbhid "\n')
+                f.write('add_drivers+="firewire-sbp2 firewire-ohci "\n')
+                f.write('add_drivers+="sbp2 ohci1394 ieee1394 "\n')
+                f.write('add_drivers+="mmc_block sdhci sdhci-pci "\n')
+                f.write('add_drivers+="pata_pcmcia  "\n')

$ for i in squashfs ext4 ext3 ext2 vfat msdos sr_mod sd_mod ide-cd cdrom ehci_hcd uhci_hcd ohci_hcd usb_storage usbhid firewire-sbp2 firewire-ohci sbp2 ohci1394 ieee1394 mmc_block sdhci sdhci-pci pata_pcmcia; do lsinitrd /boot/initramfs-$(uname -r).img|grep -q ${i}.ko || { modinfo $i &>/dev/null && echo "$i is missing";};done

usb_storage is missing
sdhci is missing
sdhci-pci is missing

ok, I'll add those missing modules to the hardcoded list of modules.
Comment 5 Harald Hoyer 2010-04-23 07:30:49 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > "add_drivers+=" does not work!    
> 
> it does, dracut.conf is simply sourced as a shell script    

doh! forgot, that we use bash in creation mode! cool!
Comment 6 Fedora Admin XMLRPC Client 2010-05-07 11:41:28 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 David Huff 2010-05-07 16:03:46 EDT
*** Bug 588622 has been marked as a duplicate of this bug. ***
Comment 9 Alan Pevec 2010-06-20 17:53:54 EDT
Accepted upstream is the better fix from bug 588622

*** This bug has been marked as a duplicate of bug 588622 ***

Note You need to log in before you can comment on or make changes to this bug.