Bug 585196 - doing yum history as a user explodes
doing yum history as a user explodes
Status: CLOSED DUPLICATE of bug 575917
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 08:12 EDT by Richard Hughes
Modified: 2014-01-21 18:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 09:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hughes 2010-04-23 08:12:58 EDT
Description of problem:

Steps to Reproduce:
1. yum history
  
Actual results:

[hughsie@hughsie-t61 yum]$ yum history 
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
ID     | Login user             | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 254, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 109, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 356, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 1314, in doCommand
    ret = base.historyListCmd(extcmds)
  File "/usr/share/yum-cli/output.py", line 1297, in historyListCmd
    for old in self.history.old(tids, limit=limit):
  File "/usr/lib/python2.6/site-packages/yum/history.py", line 446, in old
    cur = self._get_cursor()
  File "/usr/lib/python2.6/site-packages/yum/history.py", line 217, in _get_cursor
    self._conn = sqlite.connect(self._db_file)
sqlite3.OperationalError: unable to open database file

Expected results:

Nice history.

Additional info:

yum-3.2.27-3.fc13.noarch
Comment 1 seth vidal 2010-04-23 09:55:49 EDT

*** This bug has been marked as a duplicate of bug 575917 ***

Note You need to log in before you can comment on or make changes to this bug.