Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585226 - Reconcile IPA schema with 389-ds schema
Reconcile IPA schema with 389-ds schema
Status: CLOSED UPSTREAM
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
2.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 09:43 EDT by Rob Crittenden
Modified: 2015-01-04 18:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 05:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Crittenden 2010-04-23 09:43:27 EDT
Description of problem:

389-ds has changed its default schema considerably since we created the schema for IPA v2. There is now a conflict/duplication of some certificate schema. We should investigate whether there is additional schema we can remove from the customized IPA schema.

The following errors are due to the fact that 389-ds doesn't enforce this syntax yet, according to Rich Megginson. These attributes are included in the default 389-ds schema so we should simply drop these.

[23/Apr/2010:09:40:54 -0400] attr_syntax_create - Error: the EQUALITY matching rule [certificateExactMatch] is not compatible with the syntax [1.3.6.1.4.1.1466.115.121.1.5] for the attribute [userCertificate]
[23/Apr/2010:09:40:54 -0400] attr_syntax_create - Error: the EQUALITY matching rule [certificateExactMatch] is not compatible with the syntax [1.3.6.1.4.1.1466.115.121.1.5] for the attribute [cACertificate]
[23/Apr/2010:09:40:54 -0400] attr_syntax_create - Error: the EQUALITY matching rule [certificatePairExactMatch] is not compatible with the syntax [1.3.6.1.4.1.1466.115.121.1.5] for the attribute [crossCertificatePair]
[23/Apr/2010:09:40:54 -0400] attr_syntax_create - Error: the EQUALITY matching rule [certificateListExactMatch] is not compatible with the syntax [1.3.6.1.4.1.1466.115.121.1.5] for the attribute [certificateRevocationList]
[23/Apr/2010:09:40:54 -0400] attr_syntax_create - Error: the EQUALITY matching rule [certificateListExactMatch] is not compatible with the syntax [1.3.6.1.4.1.1466.115.121.1.5] for the attribute [authorityRevocationList]
[23/Apr/2010:09:40:54 -0400] attr_syntax_create - Error: the EQUALITY matching rule [certificateListExactMatch] is not compatible with the syntax [1.3.6.1.4.1.1466.115.121.1.5] for the attribute [deltaRevocationList]

Version-Release number of selected component (if applicable):

389-ds-base-1.2.6-0.3.a3.fc12.x86_64
Comment 1 Rob Crittenden 2010-09-27 14:27:56 EDT
master: 38bbe049274d8c17b1b509044afffc029cecab19

Note You need to log in before you can comment on or make changes to this bug.