Bug 585236 - QLineEdit doesn't update text when changed preedit area
Summary: QLineEdit doesn't update text when changed preedit area
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 14:03 UTC by Daisuke Kameda
Modified: 2011-04-01 19:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-01 19:12:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update QLineEdit text when updated preedit area text (1.79 KB, patch)
2010-04-23 14:03 UTC, Daisuke Kameda
no flags Details | Diff

Description Daisuke Kameda 2010-04-23 14:03:41 UTC
Created attachment 408617 [details]
update QLineEdit text when updated preedit area text

QLineControl::processInputMethod() doesn't check preedit area text.
So inputting into QLineEdit through IMEs such as xim or scim become
sluggish and unresponsive.

This bug is reported in
QTBUG-8807<http://bugreports.qt.nokia.com/browse/QTBUG-8807>.

This patch is already merged in Qt4.6.3.

Comment 1 Ngo Than 2010-04-23 17:08:11 UTC
 I will take a look at the patch, if everything is ok it will be included in tne next qt build. Thanks for your report

Comment 2 Rex Dieter 2011-04-01 19:12:43 UTC
$ koji latest-pkg dist-f13-updates qt
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
qt-4.6.3-10.fc13                          dist-f13-updates      rdieter

looks like we're good here. :)


Note You need to log in before you can comment on or make changes to this bug.