Bug 585244 - Can't bring up VPN over PPP
Can't bring up VPN over PPP
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 10:19 EDT by Dave Allan
Modified: 2016-04-26 11:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-25 03:26:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Allan 2010-04-23 10:19:57 EDT
Description of problem:
I was using my blackberry to tether and get online with barry's pppob and pppd, but when I tried to bring up a VPN connection using NetworkManager all the VPN configs (both vpnc and openvpn) were greyed out.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.998-2.git20100106.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1. Use pppd from a shell to get online
2. Try to start the VPN


Additional info:
All my network interfaces that NetworkManager knows about were down because my power was out.  I disabled networking and wireless in the hope of saving battery life, but reenabling them did not enable the VPN configs.

From my uneducated point of view, it looks to me as if NetworkManager checks to see if any networks are up before allowing the user to start VPN configurations.  If that's the case, I don't think that's a valid check.

I'm happy to try to gather more information; it's not hard to set up this configuration.
Comment 1 Dan Williams 2010-04-25 03:26:53 EDT
This is expected; if the primary internet connection you're using isn't made through NM, then the VPN connections wont' be available.  This is because NM needs various information about the current internet connection (it's gateway, PTP address, IP address, etc) before we can use VPNs, since after the VPN goes down various IP stuff needs to be reset, etc.  If you make the primary internet connection trhough NM, then the VPNs will be available through NM too.

However, if your blackberry has DUN, NM in F12 now supports DUN so you could try that.

Note You need to log in before you can comment on or make changes to this bug.