Bug 585263 - qtparted fails to start
qtparted fails to start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qtparted (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 11:03 EDT by Matthew Miller
Modified: 2010-12-15 04:06 EST (History)
7 users (show)

See Also:
Fixed In Version: qtparted-0.4.5-25.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-15 04:04:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test review of qt-parted functionality (2.03 KB, text/plain)
2010-10-27 19:49 EDT, Alexander Hunt
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 579892 None None None Never

  None (edit)
Description Matthew Miller 2010-04-23 11:03:20 EDT
Description of problem:

When qtparted starts, an error dialog is presented instead.

Version-Release number of selected component (if applicable):

qtparted-0.4.5-24.fc14.x86_64

How reproducible:

always

Steps to Reproduce:
1. install qtparted
2. run it
3. bam.
  
Actual results:

Dialog box which says "Cannot get parted version.", with an OK button.

Pressing the button exits the program.

Expected results:

Program starts.

Additional info:

Project does not look to be active. Maybe time to just drop it?
Comment 1 John 2010-05-08 14:17:17 EDT
I am having the same issue, is medium-severe issue for me.
Comment 2 Keith Wilkinson 2010-06-23 11:30:10 EDT
I am having the same issue, evident with DVD install and with LiveCD.
Comment 3 Eddie Lania 2010-07-02 15:44:36 EDT
Same here
Comment 4 Bug Zapper 2010-07-30 07:27:17 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Max Kanat-Alexander 2010-08-01 22:26:31 EDT
I can reproduce on the Fedora 13 x86_64 LiveCD as well.
Comment 6 Jeff Raber 2010-09-11 18:07:02 EDT
Linked to Debian Bug Report 579892.

According to the debian bug[1]:

"This happened because parted version is now only x.y whereas qparted
expects the version to be x.y.z.  There is a patch in qparted svn to
accommodate the parted version parsing:

http://qtparted.svn.sourceforge.net/viewvc/qtparted/trunk/qtparted/src/qp_libparted.cpp?r1=250&r2=252&pathrev=252
"

1: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=579892#22
Comment 7 Alexander Hunt 2010-10-26 19:52:59 EDT
Hi,
This is still broken in Fc14-Beta. From the research I have done, it seems the patch isn't going to be useful to anyone unless qtparted is re-built from the source files. Can anyone confirm that? 
I don't really want to install all the packaging tools on my computer if I can avoid it, but I will if it'll fix the problem for everybody (x86_64 users anyway, since I don't know how to cross-package). It would be nice if this was fixed since I think it's had the same problem from Fc12.
br,
alex
Comment 8 Jeff Raber 2010-10-26 20:07:53 EDT
Steven;
Any chance of getting this patch applied, or updating to the latest SVN snapshot from upstream?

If we cannot get this fixed, then qtparted should be deprecated as it has been completely unusable since F12.
Comment 9 Steven Pritchard 2010-10-27 11:53:08 EDT
Could you check the version I just built in rawhide?

http://koji.fedoraproject.org/koji/taskinfo?taskID=2557242

If that works, I'll push an update for F12-14 ASAP.
Comment 10 Fedora Update System 2010-10-27 13:39:37 EDT
qtparted-0.4.5-25.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/qtparted-0.4.5-25.fc13
Comment 11 Fedora Update System 2010-10-27 13:39:44 EDT
qtparted-0.4.5-25.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/qtparted-0.4.5-25.fc12
Comment 12 Fedora Update System 2010-10-27 13:39:51 EDT
qtparted-0.4.5-25.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qtparted-0.4.5-25.fc14
Comment 13 Steven Pritchard 2010-10-27 13:42:19 EDT
To make it a little easier to test, patched builds will be in updates-testing for F12-F14, plus in rawhide.  Please test (once they are available), and vote them up if they fix the problem.
Comment 14 Alexander Hunt 2010-10-27 17:15:33 EDT
Hi Steven,
Thanks for fixing the program, I installed it this morning and it opened up just fine. I'll get an HDD hooked up here and do some scientific testing to see how the partitioning and formatting operations go and report back. Might take me a day or two to test all its functions.
br,
alex
Comment 15 Alexander Hunt 2010-10-27 19:49:37 EDT
Created attachment 456118 [details]
test review of qt-parted functionality

One persons opinion after testing. 
Well the good news is the bug is resolved, on my machine anyway. The bad news is the software didn't test very well. Please see the attachment for the procedures attempted, the results and my summary. It is possible that the programs qt-parted uses to do the actual work may have something to do with how it tested.
Thanks to all those who helped get the software working again though, your efforts are very much appreciated.
br,
alex
Comment 16 Fedora Update System 2010-10-28 01:46:23 EDT
qtparted-0.4.5-25.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qtparted'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qtparted-0.4.5-25.fc12
Comment 17 Fedora Update System 2010-12-15 04:04:28 EST
qtparted-0.4.5-25.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2010-12-15 04:06:28 EST
qtparted-0.4.5-25.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.