Bug 585302 - sshfs/curlftpfs no longer working
Summary: sshfs/curlftpfs no longer working
Status: CLOSED DUPLICATE of bug 493565
Alias: None
Product: Fedora
Classification: Fedora
Component: fuse   
(Show other bugs)
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 16:19 UTC by Harald Reindl
Modified: 2010-06-04 19:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 19:23:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace snippet (3.05 KB, text/plain)
2010-04-23 16:21 UTC, Harald Reindl
no flags Details

Description Harald Reindl 2010-04-23 16:19:31 UTC
Since a longer time i am not able to use fuse-mounts via /etc/fstab
I have attached "strace mount /mountpoint" from the point where no passwords from fstab are shown

Originally i had changed UMASK like lynis recommends, not sure if this was the reason, but after upgrade to fedora 12 and restore old UMASK-Settings this does not work anyways and i have no idea where the problem is

/etc/profile:          "umask 027" 
/etc/init.d/functions: "umask 027" 
/etc/login.defs:       "UMASK 077"

/etc/bashrc:
# By default, we want this to get set.
# Even for non-interactive, non-login shells.
if [ $UID -gt 99 ] && [ "`id -gn`" = "`id -un`" ]; then
    umask 002
else
    umask 027
fi
____________________________________________

"sshfs" hangs until killing some sshfs and fuse processes with SIGKILL
"curlftps" the same with "fusermount: failed to access mountpoint Permission denied" after killing the processes as root

root 3323  0.0  0.0 111176   812 pts/1    S+   17:54   0:00 /bin/mount -i -f -t fuse.sshfs -o rw,nosuid,nodev,noexec,max_read=65536 reindl@arrakis:/Volumes/dune/www-servers/ /mnt/arrakis

root 3320  0.0  0.0  17596   992 pts/1    S+   17:54   0:00 sshfs reindl@arrakis:/Volumes/dune/www-servers/ /mnt/arrakis -o rw,noexec,nosuid,nodev,uid=500,gid=501
____________________________________________

My mountpoints in /etc/fstab are defined like followed
/etc/fstab has chmod 640, owned by root and my personal group because passwords

curlftpfs#user:pwd@host/dir /mnt/fuse1 fuse noauto,user,noexec,uid=harry,gid=verwaltung

sshfs#user@host:/dir /mnt/fuse2 fuse noauto,user,noexec,uid=harry,gid=verwaltung________________

Comment 1 Harald Reindl 2010-04-23 16:21:28 UTC
Created attachment 408669 [details]
strace snippet

Comment 2 Adam Williamson 2010-06-04 19:23:47 UTC
per reporter's request



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 493565 ***


Note You need to log in before you can comment on or make changes to this bug.