This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 585324 - Please upgrade to bzr-2.1
Please upgrade to bzr-2.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bzr (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Zeleny
Martin Cermak
: Rebase
Depends On:
Blocks: 592242
  Show dependency treegraph
 
Reported: 2010-04-23 13:38 EDT by Toshio Ernie Kuratomi
Modified: 2010-07-02 14:54 EDT (History)
6 users (show)

See Also:
Fixed In Version: bzr-2.1.1-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 14:54:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2010-04-23 13:38:17 EDT
Description of problem:

bzr in the RHEL6 beta is bzr-2.0.x.  There's a few reasons to update that to bzr-2.1.x before RHEL6 final comes out:

* Ubuntu Lucid (the Canonical long term release) is going to ship with bzr-2.1.x.  This is not a guarantee that the 2.1.x line will be supported for the life of that Ubuntu LTS release but it does increase the value of upstream maintaining 2.1.x as a supported platform.
* Important bzr plugins and tools using the bzr API have been ported to bzr-2.1.x now, not all have an active bzr-2.0.x branch.
* Fedora EPEL-5 has bzr-2.1.x (for the above reasons).  So customers migrating from RHEL-5 with EPEL to RHEL-6 will need to manually uninstall the bzr from EPEL-5 and then reinstall the bzr from RHEL-6 if they upgrade an existing host.

Thank you,
The EPEL-5 bzr maintainer
Comment 1 Toshio Ernie Kuratomi 2010-04-23 13:42:16 EDT
I was corrected on my assumption that RHEL supports upgrades between major versions rather than having to do a reinstall.  So the note about EPEL-5 vs RHEL-6 isn't so important.  IMHO, it still looks bad that a customer will have bzr-2.1.x when using RHEL-5 and have to downgrade to bzr-2.0 when switching to RHEL-6 but they won't have the manual update step to worry about.

The first two points still stand.
Comment 3 RHEL Product and Program Management 2010-04-23 14:58:47 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Jan Zeleny 2010-04-26 08:26:15 EDT
I'm setting Rebase keyword for this bugzilla. Since this is a rebase request, it has to be approved first. If you have a RHEL subscription, please file a support ticket for this issue, so it can be prioritized.
Comment 5 Josh 2010-04-26 10:55:29 EDT
I would like to see this deployed as bzr-2.1 in RHEL6 since bzr is not part of RHEL5.
Comment 6 Josh 2010-04-26 11:03:32 EDT
(In reply to comment #4)
> I'm setting Rebase keyword for this bugzilla. Since this is a rebase request,
> it has to be approved first. If you have a RHEL subscription, please file a
> support ticket for this issue, so it can be prioritized.    

What version of RHEL should the support ticket be filed against?  bzr is not a part of RHEL5 and RHEL6 is not a version option.

Thanks in advance,
-josh
Comment 7 Jan Zeleny 2010-04-27 04:27:00 EDT
I'm very sorry, I can't help you here - I don't have access to our support portal.
Comment 11 Jan Zeleny 2010-05-04 08:31:10 EDT
New package is prepared, switching status to modified.
Comment 16 Martin Cermak 2010-06-17 06:59:55 EDT
=> VERIFIED
Comment 17 releng-rhel@redhat.com 2010-07-02 14:54:23 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.