Bug 585362 - Suggest installing libsane-hpaio when an appropriate HP device is connected
Summary: Suggest installing libsane-hpaio when an appropriate HP device is connected
Keywords:
Status: ASSIGNED
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 677602 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 19:35 UTC by Eric Moret
Modified: 2020-05-28 10:55 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-23 21:18:08 UTC
Type: ---


Attachments (Terms of Use)

Description Eric Moret 2010-04-23 19:35:50 UTC
This bug is in continuation of #581005 where my scanner was not working. I eventually managed to get this working after running

$ sudo hp-plugin 

the hp-plugin command is part of hplip rpm but only works if the hplip-gui rpm is installed. Therefore I would suggest either to move hp-plugin cli to the hplip-gui rpm or to add a dependency on hplip-gui from hplip.

Comment 1 Eric Moret 2010-04-23 19:37:58 UTC
I would also suggest that upon the detection of this specific scanner a window suggesting to run hp-plugin be displayed this would make the whole experience more seemless.

Comment 2 Tim Waugh 2010-04-23 21:18:08 UTC
(In reply to comment #0)
> the hp-plugin command is part of hplip rpm but only works if the hplip-gui rpm
> is installed.

It also works if you use the '-i' option (and it says so).

(In reply to comment #1)
> I would also suggest that upon the detection of this specific scanner a window
> suggesting to run hp-plugin be displayed this would make the whole experience
> more seemless.    

Without the plugin installed, printing to the queue should indeed have this effect.

Comment 3 Eric Moret 2010-04-23 22:02:34 UTC
Indeed I overlooked the -i option, so please disregard that earlier suggestion of depending hplip on hplip-qui.

About the missing subsystems for scanner driver auto installation... is scanning considered printing to a queue? It seems the scanning function is not made available as seemlessly as printing is. To make it consistent with the "Automatic Print Driver installation" feature, http://fedoraproject.org/wiki/Features/AutomaticPrintDriverInstallation would it be possible to display a warning saying hp-plugin -i should be ran for the scanner to work or come up with some ways to let the end-user know that the scanner will not work?

Comment 4 Arnold Wang 2010-06-29 04:01:50 UTC
I'd like to report the similar experience I had. I have a HP PhotoSmart 2610 all-in-one printer/scanner/fax device. When I first tried to use "simple scan", no scanner was listed, nor do I have an option to add/install it. I have to install the "hplip-gui" package and run "hp-setup" to add/install the device driver manually. After that, the "simple scan" application recognized the scanner and started working.
I assume this was caused by the "AutomaticPrintDriverInstallation" feature which failed to recognize the multi function device I have and hence didn't install the necessary driver for the scanner.

Comment 5 Dimitri Papadopoulos 2010-07-04 09:46:15 UTC
Probably similar experience with Fedora 13 here:

I have an HP Photosmart C5390 All-in-one printer/scanner device. When I first tried to use "simple scan" or "xsane" no scanner was listed. I tried to troubleshoot using "sane-find-scanner", it did see the scanner:

$ sane-find-scanner
[...]
found USB scanner (vendor=0x03f0 [HP], product=0x7111 [Photosmart C5300 series]) at libusb:002:004
[...]
$ 

I had to install additional packages to see the scanner in "simple scan" or "xsane":
* hplip-gui
* libsane-hpaio

As far as I can recall, this used to work out of the box in Fedora 12.

Comment 6 Bug Zapper 2010-07-30 11:27:34 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Tim Waugh 2010-08-23 15:07:18 UTC
So the problems here are:

1. The hp-plugin command should be moved to hplip-gui
2. The libsane-hpaio package is not installed by default or suggested when the printer is plugged in

Comment 8 Tim Waugh 2010-12-14 16:10:57 UTC
Actually there is only one problem, if I read comment #3 right:

1. The libsane-hpaio package is not installed by default or suggested when the
printer is plugged in

Moving to system-config-printer, which is where the smart handling of USB-connecting printers is done.

Comment 9 Scott Robbins 2011-02-10 04:51:08 UTC
Fedora seems to be the only distribution that I use that has problems with this.  

The Fedora procedure seems to be, after several minimal installations:

(And judging from the forums, this seems to happen to many people with a variety of all in one machines--in my case, a C4795).

Install hplip.  Try to set up printer.  Find there's no ppd.  

Go to cups, install printer that way--ppd is found.  

Now, if you want to install it with hplip so it will scan, you have to give it a second name.  However, if one copies the /etc/cups/ppd/C4795 (in my case, due to the name I gave it) ppd to /usr/share/ppd/HP, one can now use lpadmin -x to remove the printer.

Now, if you run hplip-setup -i (for example, which is how I do it, as it's a networked printer) it will find a ppd.  However, if one runs scanimage -L they find no scanner is located.  If one then installs libsane-hpaio, it works as it should have in the first place. 

Note that this may be different if one uses Gnome, which I don't.  I have seen in the past where some package was installed by Gnome, but if one uses a more minimalistic setup, with say, just X and openbox, a needed dependency was missing.    However, one shouldn't assume that every Fedora user wants Gnome (or KDE or XFCE).  

In contrast in Arch and Debian one does the following.

Install hplip.   start cups if necessary. 

Run hplip-setup -i <ip_address>.  It finds the machine, provides a ppd.  Run scanimage -L and it finds the scanner. 

So, it seems that there is something they are doing properly that Fedora is missing.  

Perhaps libsane-hpaio should be a dependency. Not sure what the other distributions do.

Comment 10 Scott Robbins 2011-02-10 06:30:13 UTC
For what it's worth, the same issue exists in ScientificLinux 6 beta, which means it's probably in RH 6.0 as well.  Install a minimal installation, install hplip.  In this case, it does locate a ppd for the device.  

However, it won't scan till libsane-hpaio is installed.  If not fixed in Fedora, one hopes that it gets fixed in RH at least. 


I really don't think that in either case, it's a system-config-printer issue--it's an hplip issue.  There are still many of us who avoid the GUI tools, especially those of us who administer RH systems.

Comment 11 Tim Waugh 2011-02-10 09:35:08 UTC
I think it probably needs to be fixed in both places, system-config-printer and hplip.

Comment 12 Tim Waugh 2011-02-15 14:59:31 UTC
*** Bug 677602 has been marked as a duplicate of this bug. ***

Comment 13 Tim Waugh 2011-02-15 16:59:21 UTC
Fixed upstream in system-config-printer (032b5e9).

Comment 14 Scott Robbins 2011-02-15 17:10:25 UTC
Thank you Tim.   Will it be getting done in hplip as well?   If not, my feeling is that the ticket should be left open.   (Not that you've closed it, but just in case. :)  )

Comment 15 Tim Waugh 2011-02-15 17:23:24 UTC
Precisely why I left it open. :-)

Comment 16 Scott Robbins 2015-01-03 13:34:52 UTC
Same issue in Fedora 21.  :)  One needs to first add the printer in cups for hp-setup to find the ppd--I _think_ that in CentOS6, one just had to have cups running and it could create the ppd, but we're talking years ago now, and libsane-hpaio still needs to be added.

Comment 17 Tim Waugh 2015-01-05 12:10:03 UTC
Nils, any idea how this should be handled? Should the "hplip" package use the new RPM Suggests: tag to suggest libsane-hpaio? Or should libsane-hpaio just be merged back into the main hplip package?

Comment 18 Fedora Admin XMLRPC Client 2016-06-24 10:40:47 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 19 maria121 2018-12-16 17:08:35 UTC
Simply plug it in and try! If it is a newer model USB scanner, it is likely that it will work immediately without any further driver or software installations.
Hardware Support Component Scanners - check which scanners are supported in your specific Ubuntu release.
If anyone face Hp device problem then get help from this http://HPsupport365.com

Comment 20 Holt 2020-05-28 10:55:46 UTC
Update your driver and software and then plug it in. You can follow the above fellows ideas is problem still then you can get help or this : https://printererrorstate.com/hp-printer-in-error-state/


Note You need to log in before you can comment on or make changes to this bug.