Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 585364 - Use of --grow in kickstart partitioning results in / on second disk
Summary: Use of --grow in kickstart partitioning results in / on second disk
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 19:41 UTC by Orion Poplawski
Modified: 2010-04-23 19:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-23 19:57:18 UTC
Type: ---


Attachments (Terms of Use)
storage.log (136.60 KB, application/octet-stream)
2010-04-23 19:41 UTC, Orion Poplawski
no flags Details

Description Orion Poplawski 2010-04-23 19:41:05 UTC
Created attachment 408712 [details]
storage.log

Description of problem:

This is surprising to me, although perhaps it is intended behavior.  The following kickstart partitioning:

clearpart --linux
part /boot --size=200
part / --size=12000 --grow
part swap --recommended

on a system with more than one disk results in / being on different disk.  Also present in RHEL 6 beta.

Comment 1 Chris Lumens 2010-04-23 19:57:18 UTC
--grow without a maxSize tells kickstart to grow it as large as possible.  Since there's more space on your second disk (what with /boot and swap being on the first), it prefers to move the / partition over to that disk.


Note You need to log in before you can comment on or make changes to this bug.